Toilet flush broken

Discussion in 'Tech/Mech General' started by barrywi, Sep 11, 2014.

  1. barrywi

    barrywi Read Only Funster

    Joined:
    Sep 25, 2012
    Messages:
    120
    Likes Received:
    26
    Location:
    Cumbria
    On holiday in Holland and on the first flush of the electric toilet no water comes out. The motor whirs so 12 volts is there but no water comes out of the spout. It is a thetford so any clues before I hit their website?. Not sure if the pump is easily accessible as the motorhome paperwork does not have the Thetford toilet book.Luckily we have wifi here. Great site next to river Lek and Lekkerkerk. 13 euros a night including electric , hot showers and wifi that works. Are you listening Caravan Club.? Called camping De Nes. AND the sun is out too. Has Scotland gone yet?
     
  2. haganap

    haganap Funster Life Member

    Joined:
    Dec 5, 2007
    Messages:
    11,070
    Likes Received:
    13,679
    Location:
    Heavan
    not sure what van you have barry but onmine there is a similar situation what you need to do is access the pump and you may well find that one of the pipes has come off the pump so therefore it is working but just not pulling water you can access it at the blue button at the top there is a little bit of a gap ritchie prize open there is in this some sticky stuff 2 hope that helps good luck off to holland in 5 weeks can't wait
     
  3. lunarman

    lunarman Funster

    Joined:
    Sep 23, 2008
    Messages:
    1,456
    Likes Received:
    872
    Location:
    South Glos
    Is there water in the tank?
     
    • Like Like x 1
  4. Barclaybasher

    Barclaybasher Funster

    Joined:
    Apr 13, 2012
    Messages:
    2,449
    Likes Received:
    7,108
    Location:
    Derby

    Use a saucepan or kettle .............





    To Flush !


    :D(y)
     
  5. barrywi

    barrywi Read Only Funster

    Joined:
    Sep 25, 2012
    Messages:
    120
    Likes Received:
    26
    Location:
    Cumbria
    Yes there is water in the tank as I said, and I know I could use a pan, but I hate things that do not work. Thanks for the guide to where the pump may be, on a quiet day I will get my toolkit out!
     
  6. Wildbill

    Wildbill Funster

    Joined:
    Nov 18, 2011
    Messages:
    7,082
    Likes Received:
    12,079
    Location:
    Goole funster top up and elsan point
    on my van there is a fuse in the casket cabinet my one stopped working I replaced the glass fuse
    edit as haggers says probably a hose or blocked pipe
    bill
     
  7. Badknee

    Badknee Funster

    Joined:
    Aug 25, 2014
    Messages:
    3,642
    Likes Received:
    15,268
    Location:
    notloB
    Can't be much wrong if the pumps running :)
     
  8. Keef

    Keef Funster

    Joined:
    Jul 25, 2010
    Messages:
    29
    Likes Received:
    11
    Location:
    Hereford
    Had the same problem, took the van back under warranty and they came to the conclusion that the water wasn't high enough even though we had put around three or more litres in
     
  9. Wildbill

    Wildbill Funster

    Joined:
    Nov 18, 2011
    Messages:
    7,082
    Likes Received:
    12,079
    Location:
    Goole funster top up and elsan point
  10. tambo

    tambo Read Only Funster

    Joined:
    Jun 21, 2014
    Messages:
    875
    Likes Received:
    637
    Location:
    Dunfermline fife scotland
    My flush comes straight from my water tank and uses the same pump as the fresh water etc

    I'd check to make sure the supply hose hasn't come off and pumping water elsewhere
     
  11. barrywi

    barrywi Read Only Funster

    Joined:
    Sep 25, 2012
    Messages:
    120
    Likes Received:
    26
    Location:
    Cumbria
    Thanks for the suggestions everyone. Delay in replying due to internet service here going offline.
    Took off the top plate as told , undid four screws which then allow you to pull out the pump. I looked at the end of the pump and was turning when the button was pushed, so put the pump into a water container and lo and behold it pumped water! Put it all back together again and everything is fine. Don't know why it did not pump before, no pipes off and plenty of water in the tank so maybe just moving everything sorted it. Have also glued back on an edge trim and the site has fixed the internet. Three things fixed in one day and a lovely trip around Rotterdam in the sun with our Dutch friends ....result. Lovely place to visit.
     
    • Like Like x 1
  12. barrywi

    barrywi Read Only Funster

    Joined:
    Sep 25, 2012
    Messages:
    120
    Likes Received:
    26
    Location:
    Cumbria
    Still sunny in Holland ,24 degrees centifried today!
     
Loading...

Share This Page