thetford water not flowing

Discussion in 'Motorhome Chat' started by ShiftZZ, Jul 13, 2014.

  1. ShiftZZ

    ShiftZZ Funster Life Member

    Joined:
    Feb 19, 2008
    Messages:
    19,821
    Likes Received:
    35,862
    Location:
    Leicestershire
    I have a button on top of the Thetford and it was working well, but this morning its stopped flushing water. Yes, I have water, yes I have power, cant see where the fuse is.. Any suggestions? At this rate I may have to lower myself to using a public loo or a Burstner..
     
  2. Manic

    Manic Funster

    Joined:
    Nov 4, 2011
    Messages:
    855
    Likes Received:
    991
    Location:
    Uk
    On our Hymer there is a fuse inside the toilet box compartment, on the left hand side, but I'm not sure what it does. Maybe worth a look.
     
  3. DuxDeluxe

    DuxDeluxe Funster Life Member

    Joined:
    Jul 10, 2008
    Messages:
    9,332
    Likes Received:
    25,024
    Location:
    Planet Zog
    Yes, remove the cassette and have a look for the fuse. It should be there. I had a problem once when the flush tank had run dry and did not work when refilled. The pump simply needed repriming by filling up the tank very full and letting gravity do its job. However, you probably don't have a separate tank...... New van doesn't
     
  4. ShiftZZ

    ShiftZZ Funster Life Member

    Joined:
    Feb 19, 2008
    Messages:
    19,821
    Likes Received:
    35,862
    Location:
    Leicestershire
    Sorted, ta guys and Brian, I can have a Twickers now
     
    • Like Like x 1
  5. Snowbird

    Snowbird Funster Life Member

    Joined:
    Apr 24, 2009
    Messages:
    10,116
    Likes Received:
    16,298
    Location:
    Liverpool.
    Take out cassette and open slide, put hand in and at far corner you will find the fuse you are looking for. It does help if said cassette is full at the time :BigGrin:.
     
    • Like Like x 3
Loading...

Share This Page