Thetford Toilet C-200 not flusing?

Discussion in 'Tech/Mech General' started by AlphaPets, Oct 1, 2012.

  1. AlphaPets

    AlphaPets Read Only Funster

    Joined:
    Apr 4, 2012
    Messages:
    36
    Likes Received:
    1
    Location:
    Newport
    Dear All,

    Re:Thetford Toilet C-200 not flusing?

    Our toilet appears to have an intermittent fault and does not always flush. The system has been thoroughly cleaned and the electrical contact points that I can see in the cassette housing area are clean and have been sprayed with WD40 and the system has water in it. However when the flush button is pressed it makes no noise(the power is on) also the waste tank level indicator has never worked. Advice please?

    Thanks Gary

    Bessacarr E795(2004)

    :Doh:​
     
  2. GJH

    GJH Funster Life Member

    Joined:
    Aug 20, 2007
    Messages:
    27,257
    Likes Received:
    34,514
    Location:
    Acklam, Teesside, originally Glossop
    I don't know the answer but Thetford have manuals Here which may help.
     
  3. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    26,462
    Likes Received:
    25,156
    Location:
    Macclesfield
    I think there is a small blade fuse under there somewhere.
     
  4. AlphaPets

    AlphaPets Read Only Funster

    Joined:
    Apr 4, 2012
    Messages:
    36
    Likes Received:
    1
    Location:
    Newport
    The fuse appears fine, I'm guessing if it was blown, it wouldn't be an intermittent fault. :Wink:
     
  5. camocam1

    camocam1 Read Only Funster

    Joined:
    Aug 28, 2012
    Messages:
    1,112
    Likes Received:
    784
    Location:
    Elgin,Moray,Scotland
    had similar problem 2 weeks back when you open the door to access the cassette, take cassette out and right up in the very top left (on mine) of the compartment there was a small block connector which had worked slack.
     
  6. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    26,462
    Likes Received:
    25,156
    Location:
    Macclesfield
    " However when the flush button is pressed it makes no noise(the power is on) also the waste tank level indicator has never worked."

    Fooled me.
     
  7. beerdrinker1

    beerdrinker1 Funster

    Joined:
    Mar 18, 2012
    Messages:
    635
    Likes Received:
    716
    Location:
    Loch Lomond Scotland
    My Thetford C-402 packed in 6 weeks ago ( fitted to my not yet 1yr old Eldiss ), just stopped flushing completely, dead like the dodo !, checked the fuse and connector block in the cassette compartment, all fine, one dealer suggested that things may have "gummed up " between one outing and the next and to use a strong solution of Milton in the flushing tank, leave overnight and try again, did this but no joy,
    It really is inconvenient not being able to flush the bloody thing after use and having to pour a solution down the loo by hand,
    Despite the van still being under warranty, Eldiss are of no help whatsoever, referred me to the dealer who supplied the van, who are, due to me moving home again, a 7/8 hundred mile round trip away, bit far and a bit too much to spend on fuel don't you think, to rectify a small fault,
    I did contact the supplying dealer who mentioned that they had a few returned with the same problem, gave me advice to remove/dismantle the flushng mechanism panel, check it with voltage tester, which I am quite happy to do, but, of course as soon as I touch it, the warranty is void, catch twenty two situation I guess !,
    I have contacted a couple of Eldiss dealers up here in Scotland, who, quite frankly, do not want to know, then emailed Thetford for their nearest dealer , but no reply, so I am a little pissed off, I feel I an going round in circles getting nowhere
    Is this common for Manufacturers to fob off faulty products after purchase, and offer no help or assistance with their ranges, when things go wrong, makes me wonder why I bothered buying new !, :cry: :helpsos:

    Beerdrinker :drink: I NEED ONE NOW !!!!!!
     
  8. aba

    aba

    Joined:
    Oct 27, 2009
    Messages:
    2,793
    Likes Received:
    1,119
    Location:
    yorkshire
    silly question but do the taps work in the van???

    my c200 takes its water from the fresh tank and uses the main water pump.
    the indicator light only comes on when the cassette is very close to being full to the top.
     
  9. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,224
    Likes Received:
    9,612
    Location:
    Dorset
    the intermittent flush is clearly a sticky switch or bad connection. both easily sorted. or at worst a faulty pump as with the other fault above

    first do a visual check and make sure all wiring is tight then check 12v available with a meter

    if all appears ok unclip the switch panel

    use a short legth of wire to bypass switch. if it works replace switch

    if not disconnect pump and if you can, apply 12v to the pump wires.



    just thought, with some versions its not a pump but an electric valve, so you dont hear a pump in the toilet, you hear the vans pump run for a few seconds. but checking it is the same as above.... try 12v on the valve wires
    if the pump wont work direct from the battery or has gone intermittent it is better replaced than repaired as it will only fail again later

    these toilets really are simple to disassemble and work on, and all parts are readily available. simple diy skills only required
     
    Last edited: Oct 1, 2012
  10. FIDGET

    FIDGET Funster

    Joined:
    May 7, 2011
    Messages:
    2,876
    Likes Received:
    5,961
    Location:
    Isle of Wight
    Hi mine stopped working while in devon last month popped into Marquis Ivybridge ,engineer found fault pump had siezed new pump fitted , fine now. apparently common fault . £35 new pump.
    Terry:Cool:
     
    • Like Like x 1
  11. icantremember

    icantremember Funster

    Joined:
    Sep 2, 2010
    Messages:
    5,061
    Likes Received:
    7,112
    Location:
    Nr Watton in Norfolk
    Hi Gary,
    the following is a copy of a post I have just put on Beerdrinkers post who has a similar problem and it could apply to yours as well;

    "Hi Beerdrinker, we have the Thetford C-250 but get the same problem if someone pushes the flush button too hard.
    If yours is the same as ours then you need to pull the flush button panel away from the wall and you will find there is a circuit board with a micro switch behind it which just needs to be pushed back into it's holding clips and carefully replace the panel.
    Hope you will soon be flushed with success :thumb:"


    I hope this will solve your problem.

    Brian
     
  12. knokinonabit

    knokinonabit Funster

    Joined:
    Dec 28, 2011
    Messages:
    2,483
    Likes Received:
    2,455
    Location:
    Stokesley, North Yorks

    It's common for Elddis as they won't deal directly with customers.
    I have several e-mails and phone calls which Elddis have ignored.

    I now have an Auto-trail.
     
    • Like Like x 1
  13. AlphaPets

    AlphaPets Read Only Funster

    Joined:
    Apr 4, 2012
    Messages:
    36
    Likes Received:
    1
    Location:
    Newport
    Had a Motorhome Service engineer looking at doing some work to our motorhome and I mentioned the toilet. He said if you remove the panel to the flush mechanism, you need to replace the entire unit and use sealant when putting it back together. He made it sound like a big job.
     
  14. beerdrinker1

    beerdrinker1 Funster

    Joined:
    Mar 18, 2012
    Messages:
    635
    Likes Received:
    716
    Location:
    Loch Lomond Scotland

    I decided to have a look at the faulty unit on mine and dismantled it in about two seconds flat ( almost as though they knew there was an inbuilt fault and wanted to make access easy !, may be different on every model mine is C-402,
    I checked the power supply with a tester and found power was ok, so guess that the unit is faulty,
    So still no flush,but at least, no marks on unit so that when I finally get a dealer to look at it under warranty, no way they can say I have invalidated the warranty by "messing about",

    Beerdrinker :thumb: :drink:
     
  15. aba

    aba

    Joined:
    Oct 27, 2009
    Messages:
    2,793
    Likes Received:
    1,119
    Location:
    yorkshire
    can you not gain access to the rear of the panel from the cassette door????
     
Loading...

Share This Page