Thetford C2 Cassette wont flush

Discussion in 'Motorhome Chat' started by DavidAdamson, May 16, 2016.

  1. DavidAdamson

    DavidAdamson Funster

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    63
    Location:
    Manchester
    Hello,

    I have a C2 cassette loo in Delilah, I've just come back from Filey and it was my first time using the toilet since getting her, however, I've followed the protocol etc, but it just wouldn't flush with the pink and water.

    Any ideas?

    Thanks,

    David.
     
  2. Zigisla

    Zigisla Funster

    Joined:
    Oct 24, 2015
    Messages:
    999
    Likes Received:
    1,173
    Location:
    Fareham, Hants
    Check out the obvious first. Fuse for the pump. Probably inside the locker. No power due to broken wire or bad earth. Unserviceable pump impeller.
     
  3. DavidAdamson

    DavidAdamson Funster

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    63
    Location:
    Manchester
    thanks not sure where those are located, not got a manual? Is there one available online perhaps?
     
  4. Don Quixote

    Don Quixote Funster

    Joined:
    Jul 29, 2012
    Messages:
    2,500
    Likes Received:
    3,697
    Location:
    Lost in La Mancha, Spain
    @DavidAdamson firstly check that your water supply is on as ours will not flush if there is no power (run a tap) coming from the control panel. If that fails you will need to check the fuse box.
     
  5. My Dog Likes Fishing

    My Dog Likes Fishing Funster Life Member

    Joined:
    Dec 16, 2012
    Messages:
    276
    Likes Received:
    210
    Location:
    Lancashire
    Mis read it...... Was going to suggest beating it to death with the toilet brush and then try flushing it but I'll not bother now!
     
    • Like Like x 1
  6. DavidAdamson

    DavidAdamson Funster

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    63
    Location:
    Manchester
    Interesting, because there is a wire running out the back to a water pump that services the mains water, so perhaps that needs to be running with full water so it will flush?
     
  7. DavidAdamson

    DavidAdamson Funster

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    63
    Location:
    Manchester
    I nearly did...
     
  8. MH 55 FUN

    MH 55 FUN Funster

    Joined:
    Feb 18, 2016
    Messages:
    1,999
    Likes Received:
    2,941
    Location:
    South West Wales.
    Yours may, or may not, be like ours, it has it's own, seperate water flush supply so make sure there's enough water in the reservoir to enable the flush
     
    • Like Like x 1
  9. The gasman

    The gasman Funster

    Joined:
    Jun 29, 2015
    Messages:
    85
    Likes Received:
    55
    Location:
    Southampton
    Does it have a separate water tank for the flush water? If so the problem is possibly the pump. If it's like my one the pump is in the water tank. Look on you tube, lots of videos the impeller may be stuck
     
    • Like Like x 1
  10. dabhand

    dabhand Funster Life Member

    Joined:
    Feb 19, 2014
    Messages:
    1,408
    Likes Received:
    2,470
    Location:
    Staffs
    All of the above plus There is occasionally an additional inline fuse in the cassette locker, check that!
     
  11. Lenny HB

    Lenny HB Funster

    Joined:
    Oct 18, 2007
    Messages:
    5,251
    Likes Received:
    5,047
    Location:
    West Sussex
    Depends which type you have, if it flushes with water from the main tank (most Continental vans do this) then the main tank needs some water in it. If it has it's own tank which you fill via the cassette hatch then it will have a pump inside the flush tank which you can get at by pulling out the spare loo roll holder housing.
     
    • Like Like x 1
    • Thanks Thanks x 1
  12. DavidAdamson

    DavidAdamson Funster

    Joined:
    Mar 9, 2016
    Messages:
    38
    Likes Received:
    63
    Location:
    Manchester
    Its an old C2 model. I'll check the fuses, and check all of your advice thanks.
     
  13. jockaneezer

    jockaneezer Funster

    Joined:
    Dec 12, 2010
    Messages:
    1,593
    Likes Received:
    3,068
    Location:
    Cumbria
    I had a problem with the C2 in our old Adria caravan, the supply cable had a join underneath the shower tray and this had broken down due to the dreaded 12 volt dc "black lead" syndrome. I had to run a new supply cable to sort it.
     
Loading...

Share This Page