Thetford 402c will not flush

Discussion in 'Tech/Mech General' started by winterhill, May 23, 2010.

  1. winterhill

    winterhill Read Only Funster

    Joined:
    Oct 25, 2009
    Messages:
    37
    Likes Received:
    0
    Location:
    Ambleside & Bolton
    We have a Thetford 402c fitted in our 08 Auto Sleeper Symbol, Even though the flush tank is full it will not flush, the pump is working okay but the water is not getting through, maybe an air lock ?

    question is how do I prime the system or try to fix the problem any help is appreciated

    Thanks
    Leon
     
  2. Blackeunos

    Blackeunos Read Only Funster

    Joined:
    Apr 28, 2008
    Messages:
    7
    Likes Received:
    0
    Location:
    East Yorkshire
    Hi Leon,

    I had the earlier Symbol (2003) and the pump was under the toilet roll holder, not sure if yours is the same. If it is you could try giving it a shake. This used to work with caravan water pumps, the type that sat in the aquaroll. They were prone to airlocks.

    Sorry cant be of more assistance.
    regards
    Stewart
     
  3. winterhill

    winterhill Read Only Funster

    Joined:
    Oct 25, 2009
    Messages:
    37
    Likes Received:
    0
    Location:
    Ambleside & Bolton
    found the problem, it seems like a build up of gunk had blocked the clear feeder tube causing the blockage, by removing the small black u shape rubber conecter and a small piece of wire to plunge it a few times seems to have got rid of it.

    I did notice as well that you do have to continue to fill the flush tank even though you think it is full you can still get a lot more water in it, I guess it is because the water has to be pushed upwards through a U bend before it fills the clear level tube.

    hope this helps anyone else with the same problem.
     
Loading...

Share This Page