Thetford 3 Way Fridge

Discussion in 'Tech/Mech General' started by DJMotorhomer, Sep 7, 2016.

  1. DJMotorhomer

    DJMotorhomer Read Only Funster

    Joined:
    Sep 7, 2016
    Messages:
    5
    Likes Received:
    3
    Location:
    Moelfre Anglesey
    Hi

    My 3 way Thetford fridge has decided to no longer run on EHU but prefers gas.

    I have tried numerous times to get it back on EHU but to no avail, it keeps switching to gas. The error code 1 is displayed. having read up on it and knowing nowt about electrics, I checked the 5 amp fuses in the PSU and both are still intact.

    I have been advised as we are living in the van full time as we are wardens, so it runs 24/7 although the fridge is 6 years old, with continuous running the innards will have aged quicker, and the problem might well be the mains element has failed.
    Anybody had experience with this please.
    Cheers

    DJM
     
  2. WillH

    WillH Funster

    Joined:
    Feb 9, 2008
    Messages:
    1,618
    Likes Received:
    1,291
    Location:
    SW Scotland
    The 240v element has possibly burnt out. This happened to ours after four years. Spares are available on line, much cheaper than Thetford. To replace it required removing the fridge on our van, real pest of a job just to change the element. The only way to find out if it's dud is to remove it and measure it's resistance. Can't remember what the readings should be but they are on line somewhere. The process of elimination you have begun points to the element.
     
  3. icantremember

    icantremember Funster

    Joined:
    Sep 2, 2010
    Messages:
    5,061
    Likes Received:
    7,112
    Location:
    Nr Watton in Norfolk
    Definitely sounds like the 240v element .... ours went at about 4 years.
     
Loading...

Share This Page