swift 630l trip switch help

Discussion in 'Swift Motorhomes' started by olli 630L, Mar 27, 2008.

  1. olli 630L

    olli 630L Read Only Funster

    Joined:
    Feb 2, 2008
    Messages:
    8
    Likes Received:
    0
    Location:
    northants
    hi

    we have a swift 630l on a 05 plate and continue to have problems with
    the hot water trip switch on mains , as any body had the same problem
     
  2. Bryan

    Bryan Read Only Funster

    Joined:
    Jul 19, 2007
    Messages:
    2,096
    Likes Received:
    342
    Hi,

    I'm afraid that I can't help you with your query but I can say:

    Hello and :welcome: to MotorhomeFun. Tha fastest growing motorhome community in the UK :thumb:


    I hope you do get a reply to your question soon...

    Bryan
    Administrator
     
  3. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,248
    Likes Received:
    5,199
    Location:
    East Sussex 01-580-881288
    Hi and welcome to the fun site where its always cool!

    Give our service dept a ring, they should be able to help you.

    01-580-881288

    Regards
     
  4. adventure

    adventure Read Only Funster

    Joined:
    Oct 16, 2007
    Messages:
    131
    Likes Received:
    0
    Location:
    somerset
    hi olli 630l

    The most obvious problem would be the trip itself, there was a problem with the trips on the model you have, most were probably changed when they failed but as swift did no issue a recall there will be some faulty trips still about.

    Please do have it checked by a competant person to ensure that there is not an underlying problem

    Nick
     
Loading...

Share This Page