Starting Problem!!!!

Discussion in 'Fiat' started by pij974, Aug 30, 2010.

  1. pij974

    pij974 Funster

    Joined:
    Mar 17, 2008
    Messages:
    57
    Likes Received:
    7
    Location:
    Wellingborough, Northants
    Very occasionally you will turn the key in the ignition and get the relevant lights up on the dash, turn the key a bit further to start the engine and it will go completely dead, no display on the dash, no clock - nothing. I have to lift the bonnet and give the red lead a wiggle (the red lead that has a 90 degree plastic cover at the front of the posotive connections) this will then make a click noise and the clock and the trip will be reset. About 3 months ago I thought I would take the posotive connection off and have a closer look to see if there was any loose connections. There was nothing that looked obvious so I put it back together and thought I had cracked it as it has been ok until this weekend, and has now started playing up again. Any ideas?
     
  2. acting_strange

    acting_strange

    Joined:
    May 16, 2010
    Messages:
    3,398
    Likes Received:
    2,568
    Location:
    North Hykeham
    Check your earth connections.....thats a typical earth fault

    Check engine to chassis and earth from battery.... take them off, clean them and where they bolt/screw on and put them back together
     
  3. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,466
    Likes Received:
    16,915
    Location:
    YO11 2BD
    then stick a big dollop of vasaline on the connections
     
  4. acting_strange

    acting_strange

    Joined:
    May 16, 2010
    Messages:
    3,398
    Likes Received:
    2,568
    Location:
    North Hykeham
    Aaahhhhh vaseline....a great addition to your supply of personal sex aids...

    Smeared on the bedroom door handle it stops the kids from coming in and spoiling the fun:Rofl1::Rofl1::Rofl1::Rofl1::Rofl1:
     
Loading...

Share This Page