sprinter bad starting

Discussion in 'Tech/Mech General' started by spongy, Nov 4, 2012.

  1. spongy

    spongy Read Only Funster

    Joined:
    Jul 29, 2009
    Messages:
    266
    Likes Received:
    89
    Location:
    hampshire
    Motorhome is back in the mercedes dealer again, for the last year I have had a starting problem. Its intermitant, insert the key, wait for the preheat light to go out and all I get is a click from the fuse board. After several attempts at starting it normally goes but 1 day it wont. So far it has been in the workshop 4 times, new fuse board and relays £340, reset fault codes and diagnosis £110 advised it needs a new ignition module, fitted last week £660 still not cured, so back in workshop again. Anybody else had a similar problem particularly with mercedes crap.

    spongy
     
  2. jhorsf

    jhorsf Read Only Funster

    Joined:
    May 15, 2009
    Messages:
    9,157
    Likes Received:
    8,067
    Location:
    DERBYSHIRE
    see here
    [ame="http://www.youtube.com/watch?v=sZ7zZuFH58Y"]Mercedes Sprinter Van won't start - YouTube[/ame]


    it says underneath its a starter motor problem on this one
     
    • Like Like x 1
  3. spongy

    spongy Read Only Funster

    Joined:
    Jul 29, 2009
    Messages:
    266
    Likes Received:
    89
    Location:
    hampshire
    • Like Like x 1
  4. jhorsf

    jhorsf Read Only Funster

    Joined:
    May 15, 2009
    Messages:
    9,157
    Likes Received:
    8,067
    Location:
    DERBYSHIRE
    Also if you noticed in the comments

    Easy fix add 24in' ground cable to motor mount bolt back to ground on battery. (Bad MFG frame grounding system. ) Took long time to find this. Jumper cable clamp on motor back to battery ground post. BINGO> STARTED

    Anthony Martin 11 months ago
     
Loading...

Share This Page