Solar problem (maybe)

Discussion in 'Solar Power' started by Al-Di, Sep 4, 2014.

  1. Al-Di

    Al-Di Funster

    Joined:
    Mar 15, 2014
    Messages:
    900
    Likes Received:
    2,999
    Location:
    prestwich
    my regulator has a flashing red light under the panel symbol, have changed the battery as thought its was goosed, light still flashing, has a green light under batt symbol and is giving out 13.8v(10am) rising to 14.9 v after midday staying at this till sunset battery is at rest 13.8v, red light is still flashing, have cleaned the solar panel itself,

    do i have a problem ???

    Alan,
     
  2. voyagerstan

    voyagerstan Read Only Funster

    Joined:
    Aug 7, 2011
    Messages:
    323
    Likes Received:
    211
    Location:
    torquay sometimes
    no i dont think so dferent regulators flash abit diferently . reading your figuers it looks like its working ok .(y) STAN
     
  3. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    I don't think so depends on the regulator but generally telling you the battery is fully charged and the regulator has stopped putting more power in.
     
  4. andy63

    andy63 Funster

    Joined:
    Jan 19, 2014
    Messages:
    1,844
    Likes Received:
    6,409
    Location:
    south shields
    hi alan, firstly hope all well with you..
    just looked at my instructions on the pwm controller on my portable panel to see if I could help.
    the led under my panel symbol lights to show the panel is working (ie sunlight available) ,it flashes quickly to indicate battery overvoltage.. and now im confused LOL as I thought the controller would just switch the current off in those circumstances...
    your quoted voltages seem healthy so im sure all is well...
    do you have any instructions for it???
    ta andy
     
  5. Al-Di

    Al-Di Funster

    Joined:
    Mar 15, 2014
    Messages:
    900
    Likes Received:
    2,999
    Location:
    prestwich
    no instructions that I can find, but glad to hear it sounds ok, 1st battery was indeed goosed, put it on charge overnight disconnected this morning and by 1600 hrs its down to 10v,

    thanks for the help Guys, see you at Lincoln,

    Alan,
     
Loading...

Share This Page