Problem with Autotrail Kigass management system

Discussion in 'Tech/Mech General' started by Ian Richards, Mar 23, 2015.

  1. Ian Richards

    Ian Richards Read Only Funster

    Joined:
    Mar 23, 2015
    Messages:
    3
    Likes Received:
    1
    Location:
    Tadley, Hants
    Hi,
    I have a problem with the energy management system in our 2007 Autotrail Starfire camper.
    On switching on the system it only 'sees' 9 functions rather than the necessary 12 which means that it does not turn on the pump, level indicator and lights.
    I have returned this to the dealer because the van is still under warranty but I have been informed that the company Kigass went out of business years ago and so it is no longer possible to get these panels or parts. So I can see a long term problem arising.
    Has anyone else had this problem and if so how did you get over it please?
     
  2. dave newell lvs

    dave newell lvs Trader-Vehicle Services

    Joined:
    Oct 31, 2008
    Messages:
    2,513
    Likes Received:
    3,312
    Location:
    Telford, Shropshire
    Not the answer to your problem but the Starfire is an AutoCruise model not Autotrail. I know we shouldn't correct people's spelling on here but getting the name right may help to get more people to look at the thread and therefore get you a better response.

    D.
     
    • Like Like x 1
  3. Ian Richards

    Ian Richards Read Only Funster

    Joined:
    Mar 23, 2015
    Messages:
    3
    Likes Received:
    1
    Location:
    Tadley, Hants
    OOps!! Yes you are right. Thanks
     
  4. f6c

    f6c Funster

    Joined:
    Nov 7, 2010
    Messages:
    2,879
    Likes Received:
    734
    Location:
    gloucestershire
    Welcome aboard;) Sorry to read about your problem.
     
  5. keith

    keith Funster

    Joined:
    Aug 25, 2007
    Messages:
    3,258
    Likes Received:
    1,612
    Location:
    Ecclefechan
    I have the same unit in my Autocruise and I also have known about the Kiglass company going out of business. My only problem is that the ECU starts up automatically when the engine stops although once plugged in I can turn id off. So these units do seem to have problems, just keeping fingers crossed that it doesn't go wrong any further. I take it that major problems could only be cured by a replacement unit --- at some cost.
     
  6. Ian Richards

    Ian Richards Read Only Funster

    Joined:
    Mar 23, 2015
    Messages:
    3
    Likes Received:
    1
    Location:
    Tadley, Hants
    Well it is still in the hands of the dealer at the moment but the Service Manager told me that there is not a 'replacement' as such but that it could mean a rewire of the van!
    I understand that Swift bought out the Autocruise and Kigass system and replaced it with their own. Haven't looked into that side of things yet, I am waiting to hear what the dealer has to say. Will keep you posted.
     
    • Like Like x 1
Loading...

Share This Page