Peugeot 1.9td starting problems

Discussion in 'The Beginner' started by stormdog, Oct 30, 2010.

  1. stormdog

    stormdog Read Only Funster

    Joined:
    Oct 30, 2010
    Messages:
    5
    Likes Received:
    0
    Hi everyone, this year i decided to buy a MH and tour around the UK after losing my job. I bought an Autohomes Wanderer 1997 with 25k miles. Its absolutely immacualte and i love the whole MH game. Im in Belfast and travel back and forth regularly with no probs or issues until recently.
    Since my last good run across my Mh has sat for 10 days without use and now im having a problem starting her up again as the battery seems to be losing charge or so i thought. It charges after an hour or so and is fine for a couple of days then im back to charging it again.
    On the zig panel i had a red light for the engine battery telling me it was flat which was fine..but now ive still got a green light and the engine just about turns a couple of times then click click click from the starter !
    Theres a gadget on the neg terminal that is supposed to save the battery draining and i noticed that it wasnt on the post very tight...is this my problem ? Has my starter packed in maybe ?
    Ive also bought a Honda em650 generator for weekends with no hook-up and i see on it theres provision for 12v jump leads to attach. Whats the procedure for charging a battery using a genny ?

    Any advice would be a major help and much appreciated :thumb:
     
  2. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    anything loose is bad news, maybe you need to check out the battery, have you topped it up recently, as the temperature drops so bad batteries show themselves up. so top up battery acid, recharge, and clean tighten all terminals. Could be a dodgy battery but give it a chance to charge first.
    By the way you don't need to make the same post on multiple places, they all show up at the same time no matter where you post them.
     
  3. stormdog

    stormdog Read Only Funster

    Joined:
    Oct 30, 2010
    Messages:
    5
    Likes Received:
    0
    Hey thanks, ill try that tomorrow. Hopefully that should sort my wagon. :thumb:
     
  4. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,466
    Likes Received:
    16,915
    Location:
    YO11 2BD
    hi stormdog and welcome,

    charging for an hour just wont be enough.....it will bang power in but the battery wont be able to store it so it may start once or twice but thats all.

    put the battery on charge for 24 hours and see how it performs then.

    i dont think your starters shot as a ripidly clicking seloniod is normal with an almost flat battery.

    the seloniod triggers with a low current then the starter needs a high current...many hundreds of amps....so rapidly drains the already almost flat battery and the seloniod then hasnt enough power to stay connected so drops out...then the battery recovers and the seloniod clicks in again and the cycle repeats again until the battery is truely flat and cant deliver enough power to trigger the seloniod at all.
     
Loading...

Share This Page