Nordelettronica MD TE43 leisure battery charger

Discussion in 'Tech/Mech General' started by Muffinn, Nov 25, 2008.

  1. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    I have just plugged in my mains cable to a CI motorhome and do not see power reaching the leisure battery to recharge it. The mains otherwise is working in the van. I have located the unit a Nordelettronica MD TE43. I have checked all the fuses I can see but see no reset button on the unit which is awkwardly located under a front seat in a Mercedes cab. How should I proceed? Can I test that the unit is still working - there are no abvious lights on it when I connect.

    Or is it dead?
     
  2. C.L.S

    C.L.S Trader - Service & Repairs

    Joined:
    Jul 22, 2007
    Messages:
    410
    Likes Received:
    49
    Firstly i would check to see if you have power going into it , then check if there is anything coming out of the unit , you can do this simply with a multi meter.

    Mark
     
  3. Jaws

    Jaws Funster Life Member

    Joined:
    Sep 26, 2008
    Messages:
    18,351
    Likes Received:
    21,736
    Location:
    Narrfoook
    As Mark says..
    but just to clarify a little..
    Put a meter ( any cheapo one will do.. Heck, even I sell em for less than a tenner so you should be able to find one locally ok ) across the battery and see what voltage it is sitting at.
    Whilst you hold the probes on the battery get someone to plug in the mains cable.
    Hopefully you will see a little rise in the voltage when the mains is switched on...
    It will not be a BIG rise.. just as long as you see even a small one that will indicate the thing is functioning
     
  4. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    No voltage rise - the charger makes no hum or feels cold when it's been "on" so I assume it's not working. Would a charger have a fuse? Can't see any fuses that apply and they all look good?
     
Loading...

Share This Page