no 12v in motorhome

Discussion in 'Motorhome Chat' started by 2bob, Dec 1, 2013.

  1. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    need some help please
    i have no 12v in motorhome/ only 240works

    i have a nordell ettroniga battery charger i have check power comeing out by way of a light. all fuse check as far as i can find them
    i have 2 /110 batterys check the fuse all ok

    thx dave
     
  2. motorhomelover

    motorhomelover

    Joined:
    Jul 28, 2010
    Messages:
    1,720
    Likes Received:
    613
    Location:
    The world
    More info needed

    Year make model of motorhome

    Photos of the In house 12 volt. Switch board

    Photos of wife age if wife
    Sorry wrong site


    There may be a master switch. To isolate habitation electrics
    Normally a large Red key could be yellow

    Yours Ian
     
    • Like Like x 4
  3. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    Photos of wife age if wife
    Sorry wrong site

    it will cost you motorhomelover

    thx 4 reply:thumb:
     
  4. oldmanriver

    oldmanriver Read Only Funster

    Joined:
    May 24, 2013
    Messages:
    183
    Likes Received:
    179
    Location:
    gillingham kent
    had same problem in a 2008 swift kontiki, 240 coming in but no 12volt,couldnt find any faults,took control panel out, took connections off, put back together and now it works, cant find any dry joints or anything,its worth a check
     
    • Like Like x 1
  5. motorhomelover

    motorhomelover

    Joined:
    Jul 28, 2010
    Messages:
    1,720
    Likes Received:
    613
    Location:
    The world
    Whoops I did say wrong site. He he he
    Good to see you can have a laugh


    Still no photos. Honest we will
    Not black mail you with any photos given

    Yours Ian
     
    Last edited: Dec 1, 2013
    • Like Like x 1
  6. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,207
    Likes Received:
    9,588
    Location:
    Dorset
    on uk vans for you tend to find the converter fits a relay to cut 12v in the habitation when the engine is running. i have known these fail a few times

    first things first though measure voltage at the batteries with the engine and 240v battery charger off
     
  7. dogman

    dogman Read Only Funster

    Joined:
    Oct 24, 2013
    Messages:
    551
    Likes Received:
    444
    Location:
    chepstow
    first things first though measure voltage at the batteries with the engine RUNNING and 240v battery charger off ??
     
  8. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,207
    Likes Received:
    9,588
    Location:
    Dorset
    with the engine running you will measure the alternator output. the charger will also give a charge voltage. what you need to know is the voltage of the battery bank at rest. always wait an hour after charging is switched off to test battery voltage to ensure your not reading surface voltage as this will read higher

    if the battery is fully charged and the main fuse intact, then the fault is with distribution. either switched off, relay stuck open or control panel fault. not simple to diagnose over the internet, but by following a few simple steps will hopefully narrow the search

    if your battery bank is fully charged, still with 240v off, try removing the main battery fuse for 20 minutes to reset the control panel. double check fuse with a meter.

    finding the cutoff relay is not always as simple as it should be, it depends on manufacturer. some are mounted near the battery some beside or on the control board
     
  9. mobic

    mobic Read Only Funster

    Joined:
    Oct 23, 2013
    Messages:
    15
    Likes Received:
    8
    Location:
    Linlithgow, West Lothian
    location of breaker panel Swift Royale

    Hi, I see your unit is a sundance which I believe is similar to the Royale. The breaker/control panel in Nina is in the cupboard/wardrobe driver side, forward of the loo/shower room, which is nowhere near the leisure battery which is under the drivers seat. It is within a couple of feet of the hookup cable input, soI would start searching from there. There isn't much clearance and the breakers are designed with a 'hair trigger'.
    Best of luck
    Mobic:Wink:
     
  10. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    hi if these pic show their is a relay to the right thx
     

    Attached Files:

  11. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    hi my cup/wardrobe is on the near side were hook up cable is and leisure battery are 1 in floor and theother is under seat fuse all ok thx dave
     
  12. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,207
    Likes Received:
    9,588
    Location:
    Dorset
    that looks like it should be it. there are 2 thick wires, and 2 thin. connect the 2 thick wires together temporarily to see if that cures the problem. if it does, either replace the relay or if you want to use the lights in the back when driving fit a switch so you can disconnect if needed
     
  13. peter marshall

    peter marshall

    Joined:
    Mar 5, 2009
    Messages:
    2,702
    Likes Received:
    1,701
    Location:
    Cleveleys,Lancashire
    I see you say the fuses ok, I had a 20amp fuse go near the hab/ bat which knocked things off Pete
     
  14. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    thx all for the replys i think it is the charger as it is a
    nodel ettronica which have a bad report and swifte knew ab them
    when they came out .they left them in the m/h or vans then if you was unluck it would be out of warranty when you report them .same as the floors

    thx again dave
     
  15. Scottyboy

    Scottyboy Funster

    Joined:
    Oct 3, 2012
    Messages:
    165
    Likes Received:
    110
    Location:
    Hastings
    I had issues with my Nordelletronica fuse board and sent it to these guys http://www.apuljackengineering.co.uk I think he also repairs the chargers too. My problem was sorted quickly and returned fast so I would thoroughly recommend them.
     
  16. 2bob

    2bob Funster

    Joined:
    Jul 8, 2008
    Messages:
    566
    Likes Received:
    305
    Location:
    dorset
    hi scottyboy you right sent mine of today
    good report apuljack engineering they in somerset

    thx you all 4 the replys

    dave
     
Loading...

Share This Page