no 12v from generator

Discussion in 'Tech/Mech General' started by speed080, Jan 22, 2013.

  1. speed080

    speed080 Read Only Funster

    Joined:
    May 28, 2010
    Messages:
    43
    Likes Received:
    33
    hi i hope some of you wizzards can advise me
    my van has a onboard geny a wta traveller 2500 it suplies 240v ok but will not put charge into leisure batts but supplies garge to engine battery also the solar regulator(sunworks)showa fault on leisure battery side but not engine batt ,when van engine is running it charges all batterys.this has happend i think because i put van away at storage site and left on my 1000 wat inverter and the shower room lights thus flatening the leisure batts and trigerda alarm on inverter(low voltage).the van had been unattended for three weeks,all fuses and connections have been checked ,your comments will be most welcome i am in west yorks thanks in advance Dave
     
  2. Terry

    Terry Funster

    Joined:
    Dec 27, 2007
    Messages:
    10,722
    Likes Received:
    6,224
    Location:
    South yorks
    You have probably killed your leisure battery, get it tested
    Terry
     
  3. speed080

    speed080 Read Only Funster

    Joined:
    May 28, 2010
    Messages:
    43
    Likes Received:
    33
    twin 110ah i hope not
     
  4. Snowbird

    Snowbird Funster Life Member

    Joined:
    Apr 24, 2009
    Messages:
    10,141
    Likes Received:
    16,390
    Location:
    Liverpool.
    You can live in hope....but I tend to agree with Terry.
     
  5. speed080

    speed080 Read Only Funster

    Joined:
    May 28, 2010
    Messages:
    43
    Likes Received:
    33
    thanks but when van engine running the leisure batt reciive charge,but not from solar or geny when van engine off
     
    Last edited: Jan 22, 2013
  6. Terry

    Terry Funster

    Joined:
    Dec 27, 2007
    Messages:
    10,722
    Likes Received:
    6,224
    Location:
    South yorks
    Yes but are they holding the charge.? The engine will be sending the charge which I assume you are reading:Wink:
    Terry
     
  7. joner8888

    joner8888 Read Only Funster

    Joined:
    Jan 4, 2012
    Messages:
    2,190
    Likes Received:
    1,971
    Location:
    somerset
    If you completely flatten them and leave them they are dead.
     
  8. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,222
    Likes Received:
    9,602
    Location:
    Dorset
    even a dead battery will show a charge when the alternator is running and will show a trasient float voltage for a minute or 2 after, but this does not mean the battery is holding a charge.
     
  9. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    remove the hab batteries from the van and give then a full overnight charge individually then after an hour off charge take a voltage reading several hours later test the voltage again and see if it is holding.
    Though to be honest I think you have killed them. The inverter only ever need switching on when you need to use it, the rest of the time the quiescent current is wasting power.
     
  10. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,466
    Likes Received:
    16,913
    Location:
    YO11 2BD
    Looks new batteries are in order.

    once a battery reachs around 10v and not immediatly charged it,s as good as dead.
    a wild guess but your solar and 12v genny outputs may need to see some battery voltage before charging can begin.
     
    Last edited: Jan 22, 2013
  11. speed080

    speed080 Read Only Funster

    Joined:
    May 28, 2010
    Messages:
    43
    Likes Received:
    33
    thanks for info but why does the reading show no carge from genarator,the cotroll panel used to show how much charge it was recieving from geny but now shows nothing when geny is running.sorry but as youve probably realised ellecticity is not my fortey sorry last 2 posts explain im just slow at posting
     
    Last edited: Jan 22, 2013
  12. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,222
    Likes Received:
    9,602
    Location:
    Dorset
    its because virtually no current is flowing

    think of electricity being like a liquid and the battery as a jar. when its charging, or in this case the jar is filling, you can measure this. if the battery/jar is damaged and wont take a charge, virtually no current can flow or the jar wont take any more liquid. this is obviously simplified, but the analogy of electric being a liquid does explain its operation.

    your solar panel will generate electricity given the correct light conditions, but is not going to charge a dead battery. if its wired with a battery to battery type relay or charger, it will continue to maintain the engine battery
     
  13. craig

    craig Read Only Funster

    Joined:
    Jul 26, 2014
    Messages:
    1
    Likes Received:
    0
    Hi all first time poster but wont be the last!
    I have recently purchased a motor-home with a traveler 2500h geny on board that was not working.
    When i removed the cover the whole air filter unit was missing, probably in someones workshop somewhere, anyway i have been in touch with dometic who are about as much use as T*Ts on a bull. i have also rang and been to see honda specialists who said the part is something that the manufacturer would have put on as it is not the standard part.

    i have been chasing my tail for 3 weeks now and im getting nowhere fast! can anybody help me please
    Thanks in advance
    Craig
     
  14. tonyidle

    tonyidle Funster

    Joined:
    Aug 6, 2013
    Messages:
    2,871
    Likes Received:
    2,691
    Location:
    Kendal, Cumbria
    This might help:

    https://www.dometic.com/enie/International/Site/Customer-Center/Operation-Installation-Manuals/
     
Loading...

Share This Page