New Elddis Autoquest owners question!

Discussion in 'Peugeot' started by kaspian, Jun 8, 2010.

  1. kaspian

    kaspian Read Only Funster

    Joined:
    Aug 16, 2009
    Messages:
    24
    Likes Received:
    0
    Location:
    bonnie Scotland
    We have been having starting problems with our new Autoquest 130 based on the peugeot chassis . Looks like a starter motor problem but the question I have is this -
    While crawling around underneath the engine I found that the large plastic sump cover undertray is missing ! The drivers side shaped panel is present but the n/s closure panel and the large sump cover which encloses the underside of the engine are missing (from new !) . Local Peugeot garage ran the chassis number and say it should be fitted but it has obviously not been fitted or removed at some point possibly by supplying dealer or Elddis during conversion . Can any fellow owners check under the front bumper and see if your engines are enclosed by the sump guard or is this a common feature to all new Autoquests where the cover is missing and the underside of the engine exposed? Many thanks in anticipation!
     
  2. Elvis

    Elvis Read Only Funster

    Joined:
    Jun 13, 2009
    Messages:
    294
    Likes Received:
    45
    Location:
    London
    earth connection

    This may be of no help at all but we had trouble starting ours and we found that the earth wire connection had rotted, I do not know if this was because the under belly of the engine was exposed but we will have a look when we can. He is fine now and starts and runs perfectly :BigGrin:
     
  3. Steve928

    Steve928 Read Only Funster

    Joined:
    Aug 28, 2009
    Messages:
    19
    Likes Received:
    0
    Sounds the same as ours - no complete undertray, just the portion on the O/S that covers the belt and pulleys etc.

    I had a look around the local motorhome dealer once and they were all the same too, in fact I didn't realise that a complete tray was available.

    (Elddis 140 2008).
     
  4. DBSilverfox

    DBSilverfox Read Only Funster

    Joined:
    May 13, 2010
    Messages:
    592
    Likes Received:
    98
    Location:
    Nottingham
    Yep, it is the same on my Autoquest 100. The guard is only on the drivers side and only reaches in around 8 inches.

    I am assuming it is not a problem if they are all like this?

    David
     
  5. Detector

    Detector Read Only Funster

    Joined:
    Jun 4, 2010
    Messages:
    7
    Likes Received:
    1
    Location:
    South Wales
    My one month old 120 also doesn't have the cover though I'm a little suprised there's an engine.

    It seems Peugeot and Elddis are in competition to not fit/part fit or damage as many parts of the camper as possible.

    I should have been on holiday giving it a gentle run in but I'm still at home fixing things myself as the "repairs" the dealer has attempted have either been botch ups or cause more damage.

    I doubt if a call to Elddis would provide an answer as my wife and I ring every week and no one is ever able to talk "their on the other phone", "out of the office" etc etc and they never ring back. I just wish I had found this forum and seen the comments on British built products before I parted with any money.
     
  6. kaspian

    kaspian Read Only Funster

    Joined:
    Aug 16, 2009
    Messages:
    24
    Likes Received:
    0
    Location:
    bonnie Scotland
    Thanks all, for the replies! I called Elddis this morning and the girl on customer service new nothing but referred me to Peugeot customer care. I asked her to enquire on the factory floor if someone could check current build vans for sump guards but no one has got back with any info yet as they are apparently very busy .....

    Peugeot customer care UK referred me to the local Peugeot dealer and said they will look to their recommendation if it is indeed missing and/or required! The supplying motorhome dealer checked a couple in their showroom and they are both missing.

    Perhaps the most telling is , a mechanic for Peugeot said that although there are 3 parts to the undertray ie a n/s , o/s (covering pulleys and belts) and a large central section covering the engine sump area, and all are quoted as being fitted on my chassis build no. , he has rerely seen any if at all the whole trio fitted to any motorhome , chassis cab or van of the current shape!:Doh:
     
  7. nannyjan

    nannyjan Read Only Funster

    Joined:
    Mar 22, 2010
    Messages:
    126
    Likes Received:
    51
    Location:
    Forest of Dean, Glos
    Elldis Sump Cover

    When I collected my Autoquest 130 two weeks ago I enquired what the black box was that was with all the other bits and bobs you get when you collect your new vehicle. I was told it was a cover for underneath the motorhome but it was not necessary to fit it. I now use it as a tidy tray behind the passenger seat. After reading your thread I will most definitely bring this up when I take it in for its first service in 2 weeks. Will let you know the outcome. I need to enquire if my engine is ticking over too fast as it idles at over 10 on the rev counter that seems high and the brand new wiper blade that just has to be on the drivers side, just does not wipe the screen clear when raining and makes vision very difficult.

    Keep smiling :BigGrin::BigGrin:

    Nannyjan
     
  8. drs

    drs Read Only Funster

    Joined:
    Oct 13, 2007
    Messages:
    89
    Likes Received:
    0
    Location:
    Ware, Hertfordshire
    I afraid that I can't help with this problem but would just like to say that I have been having dealings with Elddis directly recently as the suppling dealer was no help. I have received nothing but kind and courteous assistance from Karen in customer care.
     

Share This Page