Motorhome Power Supply - Advice Needed

Discussion in 'Motorhome Chat' started by Jeff2008, Jun 28, 2013.

  1. Jeff2008

    Jeff2008 Read Only Funster

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Location:
    Middlesbrough
    Hello there,

    I am a newcomer to Motor homing and need some help.

    On collecting the van there was very little power in the living area. I charged up from our mains supply overnight and following day everything was fine. We went out for the afternoon , using hardly any electric , just had the fridge on for about an hour. Returned home and later in the evening I noticed there was again no electric. Overnight charged it again but this time there was no change and we still have no electrics.

    No problem with the vehicle it drives fine and all electrics there are ok.

    Any advice welcome !
     
  2. Jaws

    Jaws Funster Life Member

    Joined:
    Sep 26, 2008
    Messages:
    18,347
    Likes Received:
    21,718
    Location:
    Narrfoook
    Hi Jeff and welcome to the forum :thumb:

    It SHOULD charge the leisure battery as you drive, but it also sounds as if the leisure battery is pretty much had it I am afrad.

    The fridge should never run off of 12v when the engine is not running.. Either gas or mains, so running a fridge for however long should not discharge the battery

    Do you own a multimeter Jeff ?

    If you do, check the leisure battery voltage without the van running and not on hook up.
    Start the van and check it again.
    If it is exactly the same I would say the leisure battery charging circuit is not very well..
     
    • Like Like x 1
  3. Jeff2008

    Jeff2008 Read Only Funster

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Location:
    Middlesbrough
    Did wonder if it might be the leisure battery .Don't have a multi meter but can get hold of one and will follow your advice

    Cheers
     
  4. tonka

    tonka Funster Life Member

    Joined:
    Jul 2, 2008
    Messages:
    5,340
    Likes Received:
    7,602
    Location:
    Cannock, Staffs or Benidorm, spain
    Is this a new or used van ??
    If used then very likely the leisure battery wants to be changed..

    As suggested get a multimeter and test battery if its charging.. If it is and it doesn't keep any charge then replace..
     
  5. rangitira

    rangitira Funster

    Joined:
    Jun 30, 2010
    Messages:
    6,265
    Likes Received:
    12,443
    Location:
    Cornwall
    Sounds like the Battery is rooted:Sad:
     
  6. Jeff2008

    Jeff2008 Read Only Funster

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Location:
    Middlesbrough

    Thanks ! Will have Multi meter tonight so will test battery and go from there.
     
  7. Jeff2008

    Jeff2008 Read Only Funster

    Joined:
    Jun 28, 2013
    Messages:
    4
    Likes Received:
    0
    Location:
    Middlesbrough
    Tester battery with a multi meter and the battery is flat. Running the engine doesn't change the reading so it does look like a new battery is required.

    Thanks for the advice folks :Smile:
     
  8. Jaws

    Jaws Funster Life Member

    Joined:
    Sep 26, 2008
    Messages:
    18,347
    Likes Received:
    21,718
    Location:
    Narrfoook
    Sorry, but you have more than a flat battery problem there..

    If there is no charge going in to the battery with the engine running ( as you say, no change in the reading ) then you have a major fault in the charging system

    I would personally go right back to the dealer and explain that the van does not charge the battery when the engine is running.. You have only just bought it so they should sort it out for you :thumb:
     
Loading...

Share This Page