Mizar GTL Living - Battery won't charge!

Discussion in 'CI Motorhomes' started by Littlemiz, May 31, 2016.

  1. Littlemiz

    Littlemiz Funster

    Joined:
    May 15, 2016
    Messages:
    11
    Likes Received:
    1
    Location:
    North Wales
    Can anyone help!
    My Mizar will not charge the leisure battery with the EHU attached.
    Battery is new
    Fuses seem OK
    Battery charges OK via running engine

    Any assistance would be greatly appreciated.

    Thanks,

    Little Miz
     
  2. mitzimad

    mitzimad Funster

    Joined:
    Jan 28, 2008
    Messages:
    2,974
    Likes Received:
    3,328
    Location:
    walthamstow east london
  3. Littlemiz

    Littlemiz Funster

    Joined:
    May 15, 2016
    Messages:
    11
    Likes Received:
    1
    Location:
    North Wales
    Many thanks for the prompt reply mitzimad, can you tell me where the battery charger is located on the GTL?
     
  4. gus-lopez

    gus-lopez Funster

    Joined:
    Aug 18, 2014
    Messages:
    4,405
    Likes Received:
    8,074
    Location:
    Lorca,Murcia,Spain
    Possibly @Ralph-n-Bev might know as they used to have one.
     
    • Thanks Thanks x 1
  5. Littlemiz

    Littlemiz Funster

    Joined:
    May 15, 2016
    Messages:
    11
    Likes Received:
    1
    Location:
    North Wales
    Thanks - I will message them.
     
  6. scotzsue

    scotzsue Funster

    Joined:
    Apr 11, 2015
    Messages:
    728
    Likes Received:
    601
    Location:
    hull
    Thought at first it was your vehicle battery which was not charging on hook up, it is set up only to charge leisure battery. Wonder if previous owner has fitted a 'switchover' so you can choose which battery to charge. We have solar and a battery master, which we had fitted when we bought the van. There is a fuse on top of the battery itself, can you hear your charger (under drivers seat) has a fan which we can hear faintly when it is working.
     
  7. Littlemiz

    Littlemiz Funster

    Joined:
    May 15, 2016
    Messages:
    11
    Likes Received:
    1
    Location:
    North Wales
    Many thanks for your reply scotzsue - much appreciated.
    Problem is now resolved - a new charger has been installed.
     

Share This Page