Malaga 2 Water Heater

Discussion in 'Tech/Mech General' started by Newton, Aug 11, 2013.

  1. Newton

    Newton Read Only Funster

    Joined:
    Aug 11, 2013
    Messages:
    2
    Likes Received:
    0
    Location:
    Wakefield
    Ive got a Malaga 2 water system which ive not used for a while. When i fire up the system no water seems to be drawn out of the taps etc. There is a lot of hissing from the taps when i turn them which then dies away to nothing. When I turn the taps off, the system then 'glugs' as it starts to fill with water again. After a few seconds or even if i leave it for 30 mins I turn the tap on again and air fires out and then dies away again (no water). I would automatically suspect that there is an air lock somewhere but ive drained the main tank and the Malaga system and re-filled it again. Please help becuase I need this working by Tues!!!
     
  2. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,443
    Likes Received:
    16,872
    Location:
    YO11 2BD
    water would still come out the tap eventually even if there was an airlock.

    are you sure the water pump is working ?

    cold water will be pumped into the boiler, therefore to the open tap, as long as the pumps turned on....and running.
     
  3. mitzimad

    mitzimad Funster

    Joined:
    Jan 28, 2008
    Messages:
    2,962
    Likes Received:
    3,300
    Location:
    walthamstow east london
    Have you checked its not dumping water out under the van via the safetyvalve
     
  4. Newton

    Newton Read Only Funster

    Joined:
    Aug 11, 2013
    Messages:
    2
    Likes Received:
    0
    Location:
    Wakefield
    Im off up to have another look late this afternoon. I checked under the vehicle and no water seems to be leaking out.

    Im wondering if the pump is actually working properly. It seems to be making the right noise but the sound of water going through the system when the taps are off seems to just be a glug......few seconds....glug......few seconds.....glug and so on. It doesnt seem to have a free flow of water to the system.
     
  5. gillnphil

    gillnphil Funster

    Joined:
    Apr 12, 2010
    Messages:
    888
    Likes Received:
    3,334
    Location:
    West Suffolk
    I know whats wrong, I just fixed same problem myself. Give me a ring 07772842903.
    Regards Phil
     
  6. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,205
    Likes Received:
    9,587
    Location:
    Dorset
    would you care to share your information with the rest of us or others that have the same issue later??

    oh by the way, never a good idea to publish a phone number or email on a forum as the spammers and ambulance chasers etc will soon be bothering you with constant unsolicited calls
     
  7. gillnphil

    gillnphil Funster

    Joined:
    Apr 12, 2010
    Messages:
    888
    Likes Received:
    3,334
    Location:
    West Suffolk
    no water through boiler

    I had the same problem. It just needed an inline non return valve fitted by the water tank. That simple after much frustration. Easy self fit, just wanted to help the guy out.
    Phil
     
    • Like Like x 1
  8. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,205
    Likes Received:
    9,587
    Location:
    Dorset
    no problem Phil, I understand you wanted to help the guy out. its just the info could well help others....thankyou:thumb:
     
Loading...

Share This Page