lunar roadstar 570e positive lead problem

Discussion in 'Fiat' started by johnpc50, Mar 28, 2011.

  1. johnpc50

    johnpc50 Read Only Funster

    Joined:
    Mar 28, 2011
    Messages:
    1
    Likes Received:
    0
    Location:
    ireland
    does anyone know anything about an additional short positive lead connected to the positive terminal of the starter battery. the other end seems to have become disconnected and has a female spade connected to it. i feel that it may have become disconnected at some stage and have something to do with charging the leisure battery.the lead is identical to the normal positive cable but half the length. the year of the camper is 2000.

    regards
    johnpc50
     
  2. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,441
    Likes Received:
    16,867
    Location:
    YO11 2BD
    hi and welcome

    anythings possible and it could be as you suspect.

    have a look round the bulkhead for any relay's within cable reach which it may have come from.

    it does sound a bit extreme to have a cable that thick for the split charge though.
     
  3. sandyketton

    sandyketton Read Only Funster

    Joined:
    Aug 29, 2007
    Messages:
    334
    Likes Received:
    17
    Location:
    South West Suffolk
    Is it to connect a lead to when jump starting?
    If your Lunar is the same as mine it's a devil of a job getting a decent connection to the positive post/plate when the battery is flat.
     
Loading...

Share This Page