liesure battery not charging

Discussion in 'Tech/Mech General' started by stevesmith, Apr 26, 2013.

  1. stevesmith

    stevesmith Read Only Funster

    Joined:
    Apr 26, 2013
    Messages:
    1
    Likes Received:
    0
    Location:
    coventry
    i have a 2005 giest motor home,the liesure battery charges from the dynamo but not from the 230 ,have changed the external fusses but no succes what next? help.:Sad:
     
  2. icantremember

    icantremember Funster

    Joined:
    Sep 2, 2010
    Messages:
    5,064
    Likes Received:
    7,116
    Location:
    Nr Watton in Norfolk
    Probably a silly question, but you have checked the charger is switched on?

    Do you have 240v at the sockets in the van when on hook-up?
     
    Last edited: Apr 26, 2013
  3. motorhomer

    motorhomer Read Only Funster

    Joined:
    May 17, 2008
    Messages:
    578
    Likes Received:
    317
    Location:
    South Shropshire
    Don't know about geist specifically, but is there mains getting in to the van at all? If not, suspect something has tripped out somewhere.

    If mains is in the van and its just not charging, then perhaps there is a button or a switch on the charger itself? There is on mine, its tucked away and normally you never touch it.
     
  4. davidbaldam

    davidbaldam Funster

    Joined:
    Oct 15, 2012
    Messages:
    2,881
    Likes Received:
    6,530
    Location:
    Market Harborough
    Had the same problem myself, isolation switch had been accidentally knocked so that it was switched off, run round like an idiot for about half an hour untill it click, plonker or what, :Doh:
     
Loading...

Share This Page