Leisure battery not charging from mains on CI Cipro

Discussion in 'Tech/Mech General' started by Muffinn, Aug 20, 2008.

  1. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    My solar panel has kept the battery between 11 and 13V right through the summer. I have just reconnected to mains and notice the Nordellectronica NE 102C panel no longer says 230V when I am plugged in.

    I have checked all obvious fuses. The charger I believe is a btcina C16, at least this is the box on the other side of the mains inlet socket.

    Any suggestions very gratefully received.
     
  2. itexuk

    itexuk Read Only Funster

    Joined:
    Apr 3, 2008
    Messages:
    74
    Likes Received:
    2
    Location:
    Taunton Somerset
    Are you on site hook up or at home?
     
  3. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    CI

    I am at home - the mains works OK - the fridge and the sockets are fine. It's just the battery charger I think.
     
  4. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    With the batteries charged by solar panels they may well be fully charged so why do you expect the mains charger to be charging.
     
  5. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    Good point but the panel always used to let me know with a 230V text appearing when I was plugged in.
     
  6. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    OK it is possible that a charge from the solar panel reached a level that was too high for your control panel elecronics. maybe no diode is fitted to prevent power going where it should not? It all depends how it was wired.
     
  7. Muffinn

    Muffinn Read Only Funster

    Joined:
    Apr 17, 2008
    Messages:
    31
    Likes Received:
    0
    Location:
    Worcester
    Thanks Roger.
    Although it says 13V when I plugged in my tyre pump it groaned in using the leisure battery but was quite happy on the car cigar lighter socket - which says it's reading 12.6V
     
Loading...

Share This Page