KON-TIKI 669 Design fault

Discussion in 'Tech/Mech General' started by bigbaz, Apr 2, 2009.

  1. bigbaz

    bigbaz Funster

    Joined:
    Apr 30, 2008
    Messages:
    55
    Likes Received:
    2
    Location:
    aldridge
    Had no Heating or hot water at Newark last weekend as I couldn't get the Boiler to to come on,several mates tried toget it on but with no success,so we had to leave on Sunday (a day early)because the missus was stone cold and couldn't stand another night with no heating.

    I phoned Truma on Monday morning but they couldn't fit me in till the end of May but they gave me a phone number of Premier Towing of Tipton,phoned them up and took the van in yesterday to be fixed.

    The fault they found out was with the PCD board which had fused out due to water,this came about by a design fault by Swift(which I have let them know about this morning).

    The reason being that the drainage hole in the kitchen sink in the Kon-tiki 669 is directly above the Boiler electric box in the cabinet and there must have been a slight leak of water from there which has gone into the box and caused the PCD card to fuse.
    The PCD runs everything to do with the boiler so if it fails you have no Boiler.

    Truma say that this fault isn't covered by the Warranty so if it happens to anyone you will have to pay for it yourself to be done.The Fitter at Premier Towing said that the PCD costs £250 alone.I don't think I will be emptying water down the kitchen anymore.
     
  2. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,246
    Likes Received:
    5,197
    Location:
    East Sussex 01-580-881288
    Hi,

    Try emailing Andy Spacey at aspacey@swiftleisure.co.uk I don't think its a design fault, just a leaky connection but one never knows, Swift are pretty good at aftersales.

    Peter
     
  3. C.L.S

    C.L.S Trader - Service & Repairs

    Joined:
    Jul 22, 2007
    Messages:
    410
    Likes Received:
    49
    Can,t say its one i,ve come across before :RollEyes: have serviced several 669,s . Maybe just a loose pipe connection on your model.

    Mark
     
Loading...

Share This Page