Hymer Power Indicator Light

Discussion in 'Motorhome Chat' started by Ourwilma, Jan 18, 2012.

  1. Ourwilma

    Ourwilma Read Only Funster

    Joined:
    Jan 17, 2012
    Messages:
    3
    Likes Received:
    1
    Location:
    Merseyside
    Hi. Just replaced my old leisure battery with a new one. Previously when on EHU the power indicator light on the panel was constantly on, now since I changed the battery it flickers on and off. Is this correct, or should the light be constantly on when on EHU? It's on a 12 year old Hymer B544. Any help/advice would be greatly appreciated.
     
  2. JeanLuc

    JeanLuc Funster

    Joined:
    Nov 17, 2008
    Messages:
    2,782
    Likes Received:
    1,857
    Location:
    Warwickshire
    The light should be on all the time the 230V line is connected and the main circuit-breaker switch is on. I have no idea why yours might be flickering; I suggest a visit to a motorhome electrician is called for. Alternatively, you could try an e-mail to Udo Lang at Schaudt, the company that makes the charging and control system. He is very helpful and speaks good English. He might be able to suggest what is causing the problem.
    Udo.Lang@schaudt-gmbh.de
     
  3. rainbow chasers

    rainbow chasers Read Only Funster

    Joined:
    Oct 30, 2009
    Messages:
    3,747
    Likes Received:
    1,720
    Location:
    Mid Cornwall
    Loose wire or a bad connection. I would check the battery connection first, as it may be that the charger is finding a break in the circuit - you need a sparks to have a look at it really, but check the battery connections first to ensure the charge circuit is solid.
     
Loading...

Share This Page