High level brake light

Discussion in 'Swift Motorhomes' started by voyager 1, Aug 7, 2014.

  1. voyager 1

    voyager 1 Read Only Funster

    Joined:
    Oct 25, 2012
    Messages:
    92
    Likes Received:
    35
    Location:
    Durham Tees valley
    My swift Voyager has developed a problem with the high level brake light, it has stoped working .
    I have checked the light off the vehicle and the lights is ok, but there is no power getting to it, the two wires feeding it dont seem to be getting power . The problem is they dissapear behind the back panel of the motorhome and i cant trace where they go from there any help would be appreceated.My local swift dealer said they havn`t a clue and it might be a Fiat problem, i dont want to messs with the wireing as im no auto electrition and have no idea what this can bus system controling the electrics does.
     
  2. SandJ

    SandJ Read Only Funster

    Joined:
    Sep 14, 2007
    Messages:
    1,558
    Likes Received:
    518
    Location:
    North Yorks
  3. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    26,421
    Likes Received:
    25,078
    Location:
    Macclesfield
    Known as divide and conquer. Blame the other guy.

    Swift built and wired the body.
     
  4. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    28,934
    Likes Received:
    25,574
    Location:
    .
    My guess is that the high level light is fed from the low level brake light(s) , there may be a joint box at or near the back of the van on the chassis rail.. or it's fed directly from one of the light clusters.. Check inside both for corroded or broken wires / connections.
     

Share This Page