Help I've done something !!

Discussion in 'Auto-Trail' started by pvw10, Jul 16, 2014.

  1. pvw10

    pvw10 Read Only Funster

    Joined:
    Mar 3, 2012
    Messages:
    274
    Likes Received:
    45
    Location:
    Gloucester
    The cupboard which holds the ehu in has a light which was not needed and in the way so i removed it, i may well have caused a quick short.
    During this i heard the CD whirring(powering down i guess) and then later found its dead aaarrrgghhh.
    Its connected to the reversing camera and 10" screen for watching dvd's and doubles as the reverse camera screen all factory fit.
    So the radio is dead as is the screen so thought blown fuse, checked every fuse in the vehicle without success.
    I noted though the trip on the ehu (can't remember its name) had tripped so i did short something, reset that and everything works fine bar the Radio/screen which is 12v. I even pulled the radio to see if it had its own fuse but no joy.
    Any thoughts on where else to look ?
    2007 Renault Master base if it helps.
     
  2. jockaneezer

    jockaneezer Funster

    Joined:
    Dec 12, 2010
    Messages:
    1,593
    Likes Received:
    3,068
    Location:
    Cumbria
    When you say "all the fuses" just checking you mean the hab panel, the vehicle ones in the dash and the ones in the engine bay ? Other than a blown fuse,I can't imagine what else it could be :(
     
    • Like Like x 2
  3. pvw10

    pvw10 Read Only Funster

    Joined:
    Mar 3, 2012
    Messages:
    274
    Likes Received:
    45
    Location:
    Gloucester
    Yes the ones on the ehu, then i checked every single one (about 40) in the vehicle dash, unable to locate any more but has to be a fuse.
    Engine compartment tomorrow but from memory there all big guns in there.
     
  4. pvw10

    pvw10 Read Only Funster

    Joined:
    Mar 3, 2012
    Messages:
    274
    Likes Received:
    45
    Location:
    Gloucester
    Update.
    I later found the fridge was also dead and then the pump only worked on occasion so this was a major concern now as the beer could get warm !
    Found under one seat some more fuses/relays that i believe control the step and fridge (amazed to find the fridge fuse here) yet they were fine bar a 20amp fuse that was gone, i replace this and...............nothing.
    Last thought i unscrewed the panel covering the main wires under the ehu and wiggled all the wires and hurrah one multi plug was loose ! I pushed it back into place and every item worked perfectly again.
    So note to others, ensure all the plugs going into the bottom of the ehu are firmly pushed in.
    Now i wonder what that blown 20amp fuse protected............
     
    • Like Like x 1

Share This Page