Help for a Bessacarr Please

Discussion in 'Swift Motorhomes' started by Doddy999, May 9, 2010.

  1. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Hi All
    Just got a 2003 Bessacarr 765 fixed bed, under the bed there is a hatch I opened
    (in the middle) to my horror saw a blank hole in the plastic belly tank :Eeek:
    There is another one with a large screw cap, lying next to it are 5 wires not connected
    & two blue pipes?
    Is this where the pump should be? If so anyone know the make & model please.
    This is my first motorhome so a bit dim:RollEyes:

    Regards Doddy
     
  2. Braunston

    Braunston Read Only Funster

    Joined:
    May 21, 2008
    Messages:
    1,415
    Likes Received:
    7
    Hi,

    I don't have the same model as you so this is only a guess, but have you got a small digital panel above the entrance door or elsewhere within the motorhome that controls your charging, power selection etc etc, only if you have you may find the wires could be for the tank sensors, e.g. full, empty, partly full etc that shows on the digital read-out for your electrical control system.

    My pump is under/between the floor under a small hatch not sure where yours would be but mine definitely isn't in the tank,

    On mine the large plastic screw cap is to allow access to the inside of the tank so as to either remove the drain bung or get access to the sensors I mentioned above

    What the blank hole is I haven't a clue, other than to say my tank has 2 large plastic screw caps, Just a guess but could one of the caps been laid aside to indicate that the drain bung may of been taken out, and needs to be pushed back before the screw cap is replaced, just a thought, may have been left off as an indicator??

    hope it helps.

     
  3. Fatalhud

    Fatalhud Read Only Funster

    Joined:
    Nov 26, 2009
    Messages:
    289
    Likes Received:
    1
    Location:
    Nottingham
    On my E760 the pump is under the hatch outside the wardrobe
    To see what should be in the under bed hatch I would have to empty the compartment and look.

    It could be the wiring and hole for the tank level sensor
    If you are really struggling post again and I shall look tomorrow

    One obvious question is, Have you not tried the pump

    Alan H
     
  4. Fatalhud

    Fatalhud Read Only Funster

    Joined:
    Nov 26, 2009
    Messages:
    289
    Likes Received:
    1
    Location:
    Nottingham
    Looking at the wiring diagram the fresh water tank does have 5 wires

    Alan H
     

    Attached Files:

  5. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Many Thanks guys,
    Fatalhud yes the cables are
    Orange/White
    White
    Orange
    Blue
    Green

    Braunston Yes mine has the control panel above the door.
    There's no threaded part on the hole to screw cap onto.
    just the one cap.
     
  6. wanttobeaway

    wanttobeaway Read Only Funster

    Joined:
    Oct 26, 2009
    Messages:
    55
    Likes Received:
    0
    Location:
    on tour
    the bottom hole takes a bung /plug so it will not be threaded so check for a bung push it in then put some water in the tank and see if you have any problems
     
  7. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    I will take a couple of pics today & post them up to view. :Smile:
     
  8. motownmickey

    motownmickey Read Only Funster

    Joined:
    May 10, 2010
    Messages:
    1
    Likes Received:
    0
    Location:
    Dorset

    We have an E760
    Where did you get your motorhome from? If a dealer go back and request all the paperwork / booklets / etc
    If you contact SWIFT they will send you a handbook which should answer all your issues.

    The lid under the fixed bed gives access to the fresh water tank. You'll need a rubber bung in the bottom, and a screw cap on top. If either of these are missing suggest you go back to seller.

    Regret can't advise on wiring. If wiring is disconnected, from experience my advice would be to get it repaired by reputable company eg Essanjay in Poole

    any other issues contact me directly. keep me posted how you get on

    welcome to motorhoming - it's a very steep learning curve, even after three years :Confused:

    regards
    motownmickey
     
  9. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Here a couple of pics.

    mini-100_1337.JPG

    mini-100_1338.JPG
     
  10. Fatalhud

    Fatalhud Read Only Funster

    Joined:
    Nov 26, 2009
    Messages:
    289
    Likes Received:
    1
    Location:
    Nottingham
    Hi Doddy
    Just been out and emptied all the crap from under my bed
    The missing item is the water level sensor
    The 2 blue pipes
    1 is for the overflow this sticks out under the van
    The other I would guess is possibly a vent pipe
    Without this unit in place water will pour under the floor of your van, So It is a must that you either, replace with a new sensor or plug the hole

    Alan H
     

    Attached Files:

  11. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Hi Alan
    So kind of you to take the trouble for me. :thumb:
    I will now try to find one, probably through Swift I imagine.
    Once again many thanks.

    Regards Doddy


     
  12. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Well finally sourced one after ringing about 7 dealers with no joy in the South West.
    My local one Martins of Exeter are **** they just did'nt want to know :Angry:
    Ended up getting one from Brownhills, great service gave me the part No, posting today
    for me £102 :Eeek:
    I notice on Alans pic for me there are only four wires from unit the new one's have 5 ?
    Thanks Again for all your help. I bet I will be back shortly for mor info.
    Oh incase anyone else has this problem the Part Number is 1051166.

    Doddy
     
  13. Fatalhud

    Fatalhud Read Only Funster

    Joined:
    Nov 26, 2009
    Messages:
    289
    Likes Received:
    1
    Location:
    Nottingham
    These units are notorious for giving false reading and failing, which could be why the unit was removed in the first place
    My sensor has read 75% full for the last year, so don,t worry when yours fails again:Doh:

    Alan H
     
  14. Doddy999

    Doddy999 Read Only Funster

    Joined:
    May 3, 2010
    Messages:
    160
    Likes Received:
    13
    Location:
    Exeter Devon
    Alan thanks for that "NOT" :Wink: So I should of just blanked it off & look at my levels?

    :thumb: Doddy
     
Loading...

Share This Page