Help ! electrics/fuses ?

Discussion in 'Motorhome Chat' started by Moodybrook, Jul 7, 2013.

  1. Moodybrook

    Moodybrook Funster

    Joined:
    Jul 7, 2013
    Messages:
    754
    Likes Received:
    628
    Location:
    Dumfries
    Hi, just back from first ever outing , connected to electrics hitch on site. 240 sockets fine, later tried internal lights, Nothing ! I must have had switch settings wrong at connection. Peugeot boxer 2008 2'2 Hdi . Elddis Sunstyle 140 Where do I start. Trip switches are OK.
     
  2. callumwa

    callumwa Read Only Funster

    Joined:
    Jan 16, 2011
    Messages:
    4,113
    Likes Received:
    4,517
    Location:
    Tyne & Wear, sometimes..
    I think on the Eldiss you have some switches near the hab door, our previous 2006 Eldiss 160 did.

    If they are the wrong way around you may not have the 12V circuit switched on.
    The lights work off the 12V supply from the leisure battery even when you are on 240V hook up....


    Welcome.....:welcomefunster::welcomefunster:

    :BigGrin:
     
  3. SomeoneElse

    SomeoneElse Funster

    Joined:
    Apr 22, 2013
    Messages:
    571
    Likes Received:
    375
    Location:
    Cotswolds
    Check three things
    1. make sure the ignition is off, remove key to make sure.
    2. the large black switch next to the electric step lower/raise switch.
    3. On the control panel, set batery selection switch to "AUX".

    You should see a good 12V on th gauge, over 13V with EHU connected.
    If you have to deal with the three blue 15A fuse in the top half of the panel.

    Good luck
    Gordon
     
Loading...

Share This Page