heating sytem on a autosleeper cotswold. Diesel / electric. Problems.

Discussion in 'Tech/Mech General' started by JPS, Oct 6, 2015.

  1. JPS

    JPS

    Joined:
    Apr 20, 2015
    Messages:
    5
    Likes Received:
    7
    Location:
    aberdeenshire
    2011 model.Have any of you had the problem with Autosleeper Cotswolds heating. I have had to get the cables repaired many times due to corrosion of the cables. it is very costly when you go to the specialist agencies in Aberdeen £65 per hour. Autosleeper do not put this heating into there new motorhomes they have changes to Truma Combi 6e. It is a lovely and well set out motorhome but it is really getting us down with the continuous break downs. It looks like i will have to buy a new cable harness and have it installed. give us your experiences if you have any.
    Jim & Eve
     
  2. Neckender

    Neckender Funster

    Joined:
    Oct 15, 2007
    Messages:
    969
    Likes Received:
    1,171
    Location:
    Stoke on Trent or Benidorm
    Have look on the Auto Sleepers Owners Forum, maybe someone on there could help.

    John.
     
  3. JPS

    JPS

    Joined:
    Apr 20, 2015
    Messages:
    5
    Likes Received:
    7
    Location:
    aberdeenshire
    Thanks John. I will get onto it
    cheers Jim
     
  4. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,199
    Likes Received:
    9,581
    Location:
    Dorset
    anyone handy with a soldering iron could splice in new cables and clean up corrosion on connectors. then a bit of silicon grease would delay any recurrence. much cheaper than OEM cable harness and £65 per hour to fit it
     
  5. JPS

    JPS

    Joined:
    Apr 20, 2015
    Messages:
    5
    Likes Received:
    7
    Location:
    aberdeenshire
    Thanks Big Yin.
    Its Looks like My son and I will have to do what you are suggesting.
    its the way forward. Thanks again
    Jim
     
    • Like Like x 1
Loading...

Share This Page