Glad i had a look

Discussion in 'Tech/Mech General' started by Steve, Mar 27, 2015.

  1. Steve

    Steve Funster Life Member

    Joined:
    May 8, 2013
    Messages:
    1,599
    Likes Received:
    1,903
    Location:
    Compton Berkshire
    DSC_2368.JPG DSC_2371.JPG Passed mot last month brakes all good etc, but glad i had a look at the pads while i had the wheels off. 11 years old and 50k miles
     
    Last edited: Mar 27, 2015
    • Like it Like it x 2
  2. injebreck99

    injebreck99 Funster

    Joined:
    Dec 5, 2011
    Messages:
    1,250
    Likes Received:
    1,348
    Location:
    norfolk
    The pads looks as if they have been overheated to me!
     
  3. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    27,709
    Likes Received:
    26,809
    Location:
    Macclesfield
    We did better in 20K miles, you need to visit Switzerland.
     
    • Like it Like it x 1
  4. Moodybrook

    Moodybrook Funster

    Joined:
    Jul 7, 2013
    Messages:
    800
    Likes Received:
    651
    Location:
    Wet and cold place outside of M25
    Och, another bloomin job, Thanks ! ;)
     
    • Like it Like it x 1
  5. PeteH

    PeteH Funster

    Joined:
    Nov 22, 2007
    Messages:
    2,245
    Likes Received:
    2,787
    Location:
    East Yorkshire
    They do look as if they have been on the barbie! I had disk(s) fail once!! good job I was only going very slow at the time!!! they had corroded the Stiffeners between the Plates and Collapsed!. 2 months after MOT. when they passed with "Flying Colours" Replaced all 4
    That melted some plastic!!!!
    Pete
     

    Attached Files:

    • Like it Like it x 3
  6. Ranger

    Ranger Funster

    Joined:
    Nov 2, 2008
    Messages:
    245
    Likes Received:
    204
    Location:
    Lincolnshire
    Not seen them split like that but have seen them part company with the hub.
     
    • Like it Like it x 1
  7. Baldeagle7470

    Baldeagle7470 Funster

    Joined:
    Apr 28, 2013
    Messages:
    3,175
    Likes Received:
    1,741
    Location:
    Charente,France and Alentejo,Portugal
    Had the same,however mine were far worse than that,not long after MOT and brakes worked fine.I was shocked but garage said they see plenty of this on motorhomes that spend a long time standing and said the rust gets behind the pads causing separation,
    Scary stuff though,imagine Switzerland downhill!!
     
    • Like it Like it x 1
  8. Moodybrook

    Moodybrook Funster

    Joined:
    Jul 7, 2013
    Messages:
    800
    Likes Received:
    651
    Location:
    Wet and cold place outside of M25
    Ok Ok I am gonna check mine, soonest. You don't half ladle it on !!! :unsure:
     
    • Like it Like it x 1
  9. Baldeagle7470

    Baldeagle7470 Funster

    Joined:
    Apr 28, 2013
    Messages:
    3,175
    Likes Received:
    1,741
    Location:
    Charente,France and Alentejo,Portugal
    Haha,didn't mean to!
    In all seriousness I wish I had taken a picture,as a young'en I did a mechanics apprenticeship so been doing own maintenance for years.
    The van wheel bearings needed changing and being unwell at the time let a local garage do it.
    When he showed me the broken padsI could not believe that the brakes would even work at all,lesson learn't for me.
     
    • Like it Like it x 1
  10. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    27,709
    Likes Received:
    26,809
    Location:
    Macclesfield
    A Switzerland pad. disc.jpg
     
    • Like it Like it x 2
Loading...

Share This Page