Gas Problem... Any suggestions ?

Discussion in 'Motorhome Chat' started by Denny, May 13, 2010.

  1. Denny

    Denny Read Only Funster

    Joined:
    Mar 26, 2008
    Messages:
    55
    Likes Received:
    0
    Location:
    UK
    We have just taken our Motorhome out for it's first run this year and found that although the gas oven is working fine, the gas hob is lacking in pressure on all 3 burners, it was fine last year !
    We changed to a new cylinder ( propane ) but it made no difference.
    Has anyone had a similar experience or can anyone offer any possible reason ?
    The hob is 'CRAMER' Model 11:EK 2000 and the oven is Dethleffs the same as OUR Motorhome.
    Denny. :Sad:
     
  2. dazzer

    dazzer Read Only Funster

    Joined:
    Jul 30, 2007
    Messages:
    1,698
    Likes Received:
    99
    Location:
    In my house
    Probably a duff regulator. Do you have a spare one (maybe on a portable heater or a gas BBQ) you can swap it with to see if that solves the problem
     
  3. robnchris

    robnchris Funster

    Joined:
    Jan 11, 2010
    Messages:
    1,332
    Likes Received:
    1,566
    Location:
    Chester
    As the oven is working fine have you checked the jets on the individual burners.
     
  4. Denny

    Denny Read Only Funster

    Joined:
    Mar 26, 2008
    Messages:
    55
    Likes Received:
    0
    Location:
    UK
    Thanks for your quick reply Dazzer, but would'nt that effect the oven as well ?
    The jets seem clear Rob n Chris.......I think the problem is before gas reaches them, but not sure !
     
  5. dazzer

    dazzer Read Only Funster

    Joined:
    Jul 30, 2007
    Messages:
    1,698
    Likes Received:
    99
    Location:
    In my house
    It would effect every gas appliance, is the water heater working ok and firing up fully??

    If youve got a spare just swap it out and see if that fettles it. If not sounds like you might have a crushed/kinked pipe or a blockage in the pipework going to the burners.
     
  6. Denny

    Denny Read Only Funster

    Joined:
    Mar 26, 2008
    Messages:
    55
    Likes Received:
    0
    Location:
    UK
    The boiler worked fine as usual and as far as I can see nothing could have happened to the pipes. I'll get another regulator and try that.
    Thanks,
    Denny
     
  7. SC 05 OUT

    SC 05 OUT Funster

    Joined:
    Apr 4, 2009
    Messages:
    3,274
    Likes Received:
    6,399
    Location:
    doncaster
    run a hover end around the fleam outlets, its suprizing what can collect there,
     
  8. Dodgey

    Dodgey Funster

    Joined:
    Oct 15, 2007
    Messages:
    1,603
    Likes Received:
    227
    Location:
    Gone RVing
    Our first RV was fine at the start but after a year although everything seemed OK it was the burners that showed up a failing regulator, kettle took ages to boil:Angry:, but cooker etc seemed fine.
     
Loading...

Share This Page