Gas generator wont start

Discussion in 'Tech/Mech General' started by Soaringman, Jun 11, 2012.

  1. Soaringman

    Soaringman Funster

    Joined:
    Jan 24, 2012
    Messages:
    262
    Likes Received:
    292
    Location:
    Somerset
    I have just bought a honda EU20 generator with gas conversion, I have had an external gas point fitted to my GASLO system. I haved tried to start it as per the instructions but to no avail. When I switch the GAslo system on I have to press a priming button for 3 seconds. I have tried keeping this depressed whilst cranking the gennie and it tries to kick over but then dies :Sad: has anyone had the same, or has anyone got any tips as to how it starts?
     
  2. icantremember

    icantremember Funster

    Joined:
    Sep 2, 2010
    Messages:
    5,072
    Likes Received:
    7,121
    Location:
    Nr Watton in Norfolk
    I know that on mine I do not use any choke & there is a "bleed" valve to push which bleeds out any air.
    Brian
     
  3. Soaringman

    Soaringman Funster

    Joined:
    Jan 24, 2012
    Messages:
    262
    Likes Received:
    292
    Location:
    Somerset
    Thanks Brian
    tried that (button in the middle) still no joy, do you have yours connected through a gaslo system? or just to a gas bottle?
     
  4. icantremember

    icantremember Funster

    Joined:
    Sep 2, 2010
    Messages:
    5,072
    Likes Received:
    7,121
    Location:
    Nr Watton in Norfolk
    I have used it directly from a Calor cylinder (with a regulator) and also from our external bbq point without any problem.
    I assume you can hear gas escaping when the priming button and that you have sufficient gas in the cylinder.
    Brian
     
  5. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,484
    Likes Received:
    16,968
    Location:
    YO11 2BD
    what make is the external gas point and have you tried any other gas appliance in it ?
     
  6. Linda and Steph

    Linda and Steph Funster

    Joined:
    Jun 18, 2008
    Messages:
    1,343
    Likes Received:
    1,309
    Location:
    Lancaster
    The instructions are wrong, I had the same problem so I called the suppliers.

    I know that the instructions say to press the button for 2 - 3 seconds but this actually floods the thing. Pull the starter without any gas connected to clear it all (with the genie switched on). Then connect the gas but press the button just for about half a second rather than the 3 seconds suggested.
     
Loading...

Share This Page