Gas fire and blower system

Discussion in 'Motorhome Chat' started by RobGriff, Feb 13, 2011.

  1. RobGriff

    RobGriff Funster

    Joined:
    Aug 2, 2010
    Messages:
    109
    Likes Received:
    77
    Location:
    TONYPANDY Rhondda Wales
    Hi can anyone help I own a 1988 ducato autostratus delux camper, I have been trying to light the fire and get the blowers working which blows warm air around the camper but nothing seams to be working, Have switch the gas on and opened all the valves, thanks Robert :Smile:
     
  2. JJ

    JJ Funster

    Joined:
    May 1, 2008
    Messages:
    14,552
    Likes Received:
    25,677
    Location:
    Quinta Majay, Pinheiro Bordalo, Portugal
    Hi there Robert

    I have a 1987 Hymer 660 with a Truma blown air heating system and might be able to help you if your system is the same or simliar... can you post details of which heater yours is...

    JJ
     
  3. mike mcglynn

    mike mcglynn Funster Life Member

    Joined:
    Jan 6, 2008
    Messages:
    1,398
    Likes Received:
    4,751
    Location:
    St. Helens MERSEYSIDE
    fire trouble

    Hi, Robert sometimes its the cover on the external vent have you remembered to take it off
    as the system wont work with this on.... its a safety device hope this helps
    as sometimes it the daftest things that take the longest time to suss out :thumb:
     
  4. Loujess

    Loujess Read Only Funster

    Joined:
    Jan 10, 2010
    Messages:
    3,261
    Likes Received:
    3,168
    Location:
    Leeds UK
    I find it usually need a new battery to give the spark. :Smile:

    Ivy
     
  5. peter marshall

    peter marshall

    Joined:
    Mar 5, 2009
    Messages:
    2,702
    Likes Received:
    1,701
    Location:
    Cleveleys,Lancashire
    Hi Robert
    It might be the outside cover like Mike said, I had the same trouble once it was the 20amp fuse on the leisure battery, worth a look at, does you hob ignite mine was on the same fuse. Pete :thumb::thumb:
     
  6. Squire

    Squire Read Only Funster

    Joined:
    Dec 30, 2010
    Messages:
    324
    Likes Received:
    60

    When you say 'nothing seems to be working', what do you mean?

    Do you mean that you can't get get the gas to light in the heater?
    Have to made sure that there's still gas in the bottle after winter storage?

    Can you get an ignition spark? (If you can't actually see it, you should be able to hear it)

    Have you remembered to keep the 'gas by-pass' valve pressed while you try the ignition at the same time ?

    Is your ignition system powered by a dry cell battery usually located in the base of the heater? If so, have you checked it out? It may not be flat - it could be corroded or dirty contacts. Or is it a Pietzo crystal (push plunger button each time to generate a spark) igniter?

    When you switch on the blower fan, does it run? Can you hear it? It should work whether the heater lights or not. If not - have you checked the 12v fuses? Do other 12v services work OK, such as light?

    Your question is a lot more complicated than it sounds because there are several different makes of heaters fitted all of which have differing modus operandi.

    The make and model of the heater would be more useful than the make and model of the motorhome - unless someone here has exactly the same age and model of van ...... ??
     
Loading...

Share This Page