fridge won't work on hook-up

Discussion in 'The Beginner' started by DaveandChris, Mar 5, 2010.

  1. DaveandChris

    DaveandChris Read Only Funster

    Joined:
    Sep 7, 2009
    Messages:
    6
    Likes Received:
    0
    We have just come back from our first week-long holiday, we have been away for a weekend before. Our motorhome is an Autocruise Starspirit and has a Thetford N80ELR fridge, I don't know what type but it has three buttons at the top, one for connecting to hook-up,gas or battery, one for showing the flame is lit and one for the temperature. The temperature button also acts as the ignitor to turn on the flame.

    Previously we have been able to use the fridge on any connection but we can now only get a flame when connected to gas.

    Can anyone help? We have checked the fuses.
     
  2. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,441
    Likes Received:
    16,867
    Location:
    YO11 2BD
    unless your electrics have mystical powers you never will get a flame on electric, either 12v or 230v :Rofl1::Rofl1:

    the electrical side heats a basic element and if its not getting cold there must be a fault in the fridge or supply.
     
  3. Johns_Cross_Motorhomes

    Johns_Cross_Motorhomes Trader - Motorhome & Accessory Sales

    Joined:
    Jan 5, 2008
    Messages:
    9,246
    Likes Received:
    5,197
    Location:
    East Sussex 01-580-881288
    Hi,

    It could be the heater element for 240v, give Glenn or Ian a ring and they will advise

    Peter
     
  4. chatter

    chatter Read Only Funster

    Joined:
    Aug 3, 2009
    Messages:
    3,723
    Likes Received:
    939
    Location:
    cheshire
    are you trying to say it was the flame button not lighting that gave cause for concern if so pappajohn is right , and if not, did you check wether it was actually cooling when on ehu and have you set the temperature/choice of power supply button right.
     
  5. Taran_Las

    Taran_Las Funster

    Joined:
    Mar 26, 2009
    Messages:
    6,476
    Likes Received:
    5,517
    Location:
    Near Mold North Wales
    On my 04 Starspirit (not sure which model fridge) the selector switch (for gas, 240v etc) had split behind the switch. Even though the selector moved to the different positions it wasn't moving the selector spindle. This resulted in the fridge only working on the source it was stuck on. Not sure if this helps any but feel free to PM if it doesn't make sense.

    Phil
     
  6. DaveandChris

    DaveandChris Read Only Funster

    Joined:
    Sep 7, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for all your help

    The fridge will only work on gas, not ehu or battery.

    There is a meter which goes in to green when the fridge is working, it will only go in to the green when we are using gas.
     
  7. ubuntu1

    ubuntu1 Read Only Funster

    Joined:
    Feb 13, 2008
    Messages:
    155
    Likes Received:
    44
    Location:
    Derbyshire
    fridge

    Its a simple check for an engineer and if its just the element then its not too expensive. The 12v will only work from the engine battery and only when the engine is running. Its not designed to chill but to hold the temperature.

    I suggest finding an engineer to carry out the diagnostics for you, take a look at mcea.
     
Loading...

Share This Page