Fridge vents

Discussion in 'Top Tips & Tricks' started by Hettie's Crew, Apr 23, 2016.

  1. Hettie's Crew

    Hettie's Crew Funster

    Joined:
    Sep 28, 2015
    Messages:
    100
    Likes Received:
    60
    Location:
    Kingston upon Hull
    Dometic 8505 with LS300 vents.
    I had the vents on, as per instructions, when the temperature is below 10c. On the east coast there have been brief periods during the day with the temperature being slightly above 10c, but not many.
    Fridge not getting cold, though freezer ok.
    Could feel heat on the top vent and inside, on the fridge carcase.
    Took the top cover of yesterday and all is well again. Fridge cold and heat gone. These LS300 covers close off about 95% of the vent, leaving just a very small slit at the bottom.
    I think I shall only use them if it is around freezing, if at all.
    This is on EHU.
     
    Last edited: Apr 23, 2016
  2. Robert Clark

    Robert Clark Funster Life Member

    Joined:
    Jul 12, 2014
    Messages:
    5,624
    Likes Received:
    9,888
    Location:
    East Sussex
    We had the same issue when running on gas
     
  3. mpdcymru

    mpdcymru Funster

    Joined:
    May 16, 2014
    Messages:
    348
    Likes Received:
    424
    Location:
    Ammanford
    During the run up to a cold period I often use just one of the covers (bottom one) and that seems to work a treat. Don't know if there are any technical reasons behind that but it works!
     
Loading...

Share This Page