Fridge not working

Discussion in 'Tech/Mech General' started by bethanflowers, Mar 24, 2016.

  1. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    Burstner Marano laid up over winter, habitation electrics isolated.
    Connected last month to 240V to run a low power tubular heater.

    Habitation electrics turned back on today, everything working apart from the fridge, not showing any lights in 12V, 240V or Gas setting.

    Any advice greatly appreciated

    PS unavailable for replies until 11pm
     
  2. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    PS unavailable for replies 7pm to 11pm
     
  3. mickyc

    mickyc Read Only Funster

    Joined:
    Nov 30, 2009
    Messages:
    566
    Likes Received:
    2,013
    Location:
    Spain/Portugal
    Fuse?

    Flat leisure battery?

    Bulb in fridge light?

    Does fridge work (ie get cold)?
     
    • Like Like x 1
  4. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    Thanks MickyC,
    Fuse - no specific fuse, but all visible fuses checked
    Flat leisure battery - no
    Bulb in fridge light - no internal bulb, only fridge control panel indicator, which is currently not lighting up
    Does fridge work (ie get cold) - have now switched on and will leave on until 11pm
     
  5. landscaper

    landscaper Funster

    Joined:
    Mar 17, 2013
    Messages:
    233
    Likes Received:
    164
    Location:
    Devon
    Don't suppose you are parked on a slope?
     
  6. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    Hi landscaper
    Yes, we are parked on a slope, but we always have been.
    And why would it affect the electric light?
     
  7. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    Just to add ...
    Wondering if it could be something in the elektroblock control unit under the driver's seat - where the isolation switch is - as it looks like no power getting to the fridge. Might try switching that off then back on when we get back
     
  8. landscaper

    landscaper Funster

    Joined:
    Mar 17, 2013
    Messages:
    233
    Likes Received:
    164
    Location:
    Devon
    Hi there, sorry didn't read properly and see it was the light affected - just that our fridge will not work at all when our van is parked on any incline. It took us ages to work this out!
     
    • Informative Informative x 1
  9. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    OT disconnected 240V from van and habitation alarm light is flashing, maybe habitation battery is shot.
    Van is a 56 reg so if it's the original battery, it's over 10 years old.
    Going to check it with a voltmeter in the morning.
    Now, where to buy a leisure battery between Stockport and Carlisle on Good Friday?!!
     
  10. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,212
    Likes Received:
    9,592
    Location:
    Dorset
    I was going to say it sounds like the leisure battery is dead. not always obvious when hooked up to 240v as the charger will confuse things.

    as a last resort Halfords are open over the easter holiday and stock leisure batteries
     
  11. gillnphil

    gillnphil Funster

    Joined:
    Apr 12, 2010
    Messages:
    893
    Likes Received:
    3,372
    Location:
    West Suffolk
    The fridge fuse is a separate one from all the others. Look in the hand book to see which one.
    Phil
     
  12. bethanflowers

    bethanflowers Funster

    Joined:
    Nov 8, 2012
    Messages:
    9
    Likes Received:
    0
    Location:
    Stockport
    Thanks Thebig1 and phil.
    Battery now checked (disconnected from 240V) and is fine
    Fridge fuse located and checked
    Control unit hoovered in case of dust issues
    Still no lights on fridge control panel indicator and fridge not cooling on 240V

    And just to add another spanner into the works, cab radio now not working!!

    Lots of head scratching going on

    thanks everyone who is trying to help
     
Loading...

Share This Page