fridge help please

Discussion in 'The Beginner' started by frosty, Apr 5, 2011.

  1. frosty

    frosty Read Only Funster

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Location:
    worthing
    hello everyone i have a electrolux 3way fridge im not sure of the model but think it might be a RM4401? it doesn't have the view glass to see if the flame is alight,it only has the electronic ignition.the fridge has been really good until the last few trips,12volt is good,hook up on 240 its excellent and gas has been excellent,but now i come to put it on to gas i turn the gas on and switch the electronic ignition on and i can hear it light up the gas but the ignition keeps sparking on and off?some times its only flashing every few minutes and some times faster,some times its flashing continuously like i havnt turned the gas on,i have tried getting any air out by turning on the cooker ect but still the problem,if you have any info thank you:thumb: regards simon
     
  2. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    Hi and welcome to the forum. I wonder did you remember to take the winter covers off the vents?
     
  3. frosty

    frosty Read Only Funster

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Location:
    worthing
    hi i didnt even no the vents had a winter cover for the fridge i have just been out to my van and the fridge vent is open but where the heat comes out of the grill it does have a cover over that little part of the grill but i have never taken it off be for but i will try it now,thanks for info and will let you no
     
  4. frosty

    frosty Read Only Funster

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Location:
    worthing
    no i tried again and again i could hear it light the gas but the red flashing light is still flashing all be it its flashing slower than when the gas is off.i have loads of gas and vents are clear.
     
  5. scotjimland

    scotjimland Funster Life Member

    Joined:
    Jul 25, 2007
    Messages:
    28,934
    Likes Received:
    25,574
    Location:
    .
    sounds like the burner needs a service/cleaning, also check that the thermocouple point is in the hot part of the flame.. (tip of blue flame cone)

    if that doesn't resolve it then suspect a faulty thermocouple, easy and to replace ..

    if still not resolved faulty ignitor board ... change.
     
  6. frosty

    frosty Read Only Funster

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Location:
    worthing
    hi yes i think a service is the order of the day,would anyone no of anyone who could do the job for me in sussex.and not likely to rip me off lol
     
  7. Ash

    Ash Trader - Service & Repairs Life Member

    Joined:
    Sep 22, 2007
    Messages:
    766
    Likes Received:
    189
    Location:
    The Midlands ( Nuneaton )
  8. MikeandCarolyn

    MikeandCarolyn Read Only Funster

    Joined:
    Mar 18, 2008
    Messages:
    2,171
    Likes Received:
    1,463
    Location:
    Worle,North Somerset
    We had similar problem in France last year-a French technician said it was the gas valve and got it working with a sharp tap on the valve body from a rubber handled screwdriver.
    It packed up again after we got back and our local guy gave the burners a good clean and service. So far it's been ok :Smile:

    Mike.
     
  9. frosty

    frosty Read Only Funster

    Joined:
    Mar 5, 2010
    Messages:
    26
    Likes Received:
    0
    Location:
    worthing
    thanks so much for replys
     
Loading...

Share This Page