Fresh water pump help, please

Discussion in 'Motorhome Chat' started by Swiftroy1, Nov 9, 2012.

  1. Swiftroy1

    Swiftroy1 Read Only Funster

    Joined:
    Jan 3, 2010
    Messages:
    180
    Likes Received:
    172
    Location:
    Bedfordshire
    I had a failed fresh water tank pump which I've replaced with a similar lt/min rating but the flow now isn't a strong as the original one. The pump is an immersion type. Could someone please advise what could be the cause.

    Roy
     
  2. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,215
    Likes Received:
    9,592
    Location:
    Dorset
    the obvious would be a lower ltr per min from the pump than its rated at. could be a bit stiff as new or a bad electrical connection

    other options include a kinked pipe or partial blockage... what caused the last pump to fail? as its not unknown with submersible pumps for their impeller to break up and could get into the pipe. the debris tends to catch at a connector and block the flow. often accompanied by little bits of plastic coming out of the tap with water
     
  3. Swiftroy1

    Swiftroy1 Read Only Funster

    Joined:
    Jan 3, 2010
    Messages:
    180
    Likes Received:
    172
    Location:
    Bedfordshire
    The original pump suffered an internal electrical failure. On inspection it had burnt 2 holes in the casing and blew the fuse. It didn't appear to have shed any bits and looked complete. I'll check the pipework. thanks for your advice.

    Roy
     
  4. Pikey Pete

    Pikey Pete Read Only Funster

    Joined:
    May 25, 2008
    Messages:
    1,532
    Likes Received:
    1,141
    Location:
    o
    Ignore the colour coding and reverse the electrical connections.



    Pete:Cool:
     
Loading...

Share This Page