Fiat 2.3 won't start when warm.

Discussion in 'Fiat' started by windsurf, Mar 13, 2011.

  1. windsurf

    windsurf Read Only Funster

    Joined:
    Nov 23, 2010
    Messages:
    9
    Likes Received:
    3
    Location:
    uk
    Any ideas please...just came back from a skiing holiday in France,no problems until after turning the ignition off at the channel tunnel it would not start again for 15 minutes.It done the same when we got home & again a couple of days later.Its a 2007 2.3 8000miles...
     
  2. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    possible ECU confuser problem try disconnecting the battery for 10 mins to let it reset
    assuming your van is safe to disconnect.
     
  3. callumwa

    callumwa Read Only Funster

    Joined:
    Jan 16, 2011
    Messages:
    4,113
    Likes Received:
    4,517
    Location:
    Tyne & Wear, sometimes..

    If it starts after 15 minutes, its not worth the effort to disconnect the battery and wait 10 minutes. Did you try to remove the ignition key, lock and immobilise the van, then unlock again, maybe it's an immobiliser problem..

    They can and do have minds of their own sometimes.......
     
  4. windsurf

    windsurf Read Only Funster

    Joined:
    Nov 23, 2010
    Messages:
    9
    Likes Received:
    3
    Location:
    uk
    Have taken keys out,locked & unlocked but still have to wait.Engine spins over but no sign of it starting
     
  5. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    I was not suggesting it would need doing more than once, just give the ECU a chance to reset and sort itself out. a once only jobbie. Might just sort it if not then next suggestion please.
     
  6. 1948

    1948 Read Only Funster

    Joined:
    Dec 3, 2009
    Messages:
    444
    Likes Received:
    46
    Location:
    surrey
    had same symptoms with a renalt espace once, would not start when hot, local garage could not fix ( many years ago) Took car to dealer, plug in computer found fault and fixed within 1/2 hour, could not remember parts were changed or not, but did remember not costing a lot.
     
  7. callumwa

    callumwa Read Only Funster

    Joined:
    Jan 16, 2011
    Messages:
    4,113
    Likes Received:
    4,517
    Location:
    Tyne & Wear, sometimes..
    Is the problem happening every time when the engine is hot, or is it a dreaded intermittent fault?
     
  8. windsurf

    windsurf Read Only Funster

    Joined:
    Nov 23, 2010
    Messages:
    9
    Likes Received:
    3
    Location:
    uk
    everytime
     
  9. rainbow chasers

    rainbow chasers Read Only Funster

    Joined:
    Oct 30, 2009
    Messages:
    3,747
    Likes Received:
    1,720
    Location:
    Mid Cornwall
    Possible air leak - what she like cold?
    Relays also prone on these.
    The air leak COULD be caused by the fuel rail, which was a recall - but you are around the changeover year - so depends on ther engine number! I would check all fuel lines for leaks, return pipes especially if it is cranking and not starting.
     
  10. windsurf

    windsurf Read Only Funster

    Joined:
    Nov 23, 2010
    Messages:
    9
    Likes Received:
    3
    Location:
    uk
    I have not had a problem when its been started from cold but i have taken it back to the dealer to sort & they say they have had problems when cold.They have had the injector pump checked ok & suspect a faulty electrical signal to the pump....just thought there are no new problems & someone may have had a similar problem.When it runs it has been faultless
     
  11. windsurf

    windsurf Read Only Funster

    Joined:
    Nov 23, 2010
    Messages:
    9
    Likes Received:
    3
    Location:
    uk
    Just thought i would drop a note to conclude my problem.After leaving it with the dealer they found that the ecu was at fault & changed it under warranty,not only that they handed the van back cleaner than it was when new superb service from TC Motorhomes in Herne Bay Kent.Many thanks for all your responses........
     
Loading...
Similar Threads
  1. Fletton
    Replies:
    1
    Views:
    221
  2. Jez and Lin
    Replies:
    8
    Views:
    422
  3. lunarman
    Replies:
    3
    Views:
    348
  4. Clayton9
    Replies:
    14
    Views:
    784
  5. WillH
    Replies:
    27
    Views:
    1,851

Share This Page