Electric Problem

Discussion in 'Introduce Yourself' started by davidb1327, Nov 17, 2013.

  1. davidb1327

    davidb1327 Read Only Funster

    Joined:
    Nov 17, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    Brigg
    Hi,
    I'm totally new to motorhoming and have come up against a problem with the electrics (or maybe it's me doing or not doing something)

    Each time I come off being on an electrical hook-up I find the leisure side batteries are showing flat. I drive a few miles to recharge :helpsos:and thereafter I have no problems until I use the mains hook-up again. The switch is on "van" all the time and I'm wondering if I should switch to "car" when hooked up as I do when mobile. Maybe there is something else I'm not doing or could it be a battery problem. I have a solar panel which is in full working order. Any advice would be greatly appreciated......Hope someone can help...

    Regards

    Dave Brown
     
  2. ourcampersbeentrashed

    ourcampersbeentrashed Funster

    Joined:
    Apr 19, 2008
    Messages:
    7,652
    Likes Received:
    4,284
    Location:
    East London
    Hi David and welcome to fun

    I am sure someone with better knowledge than me will be along soon to help you
     
  3. davidb1327

    davidb1327 Read Only Funster

    Joined:
    Nov 17, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    Brigg
    Thanks for the Welcome

    Thank you for the welcome. I hope someone can help as I don't think the problem can be too involved. Still, I'll wait and see what develops....Thanks again
     
  4. peter H

    peter H Funster Life Member

    Joined:
    Jan 18, 2008
    Messages:
    1,350
    Likes Received:
    661
    Location:
    Neath, South Wales
    Hi David and welcome.

    Some more details would be welcome, before the experts on here get going.

    Like: what van/car switch?
    What sort of van
    What sort of battery charger.

    More detail the better.

    Peter
     
  5. Caztur

    Caztur Funster

    Joined:
    Jan 31, 2009
    Messages:
    335
    Likes Received:
    136
    Location:
    Shropshire
    On my van the rocker switch has to be in the central "off" position when on EHU to charge the battery; in this position the power for the 12v circuit is being provided from the mains and the battery is being charged, by the transformer.

    The switch in the "van" position means the internal 12v circuit is running from the leisure battery, it isn't being charged.

    But every van I have seems to be wired up differently! Others haven't been like this.
     
  6. lunarman

    lunarman Funster

    Joined:
    Sep 23, 2008
    Messages:
    1,455
    Likes Received:
    872
    Location:
    South Glos
    It sounds to me like the battery charger is turned off.

    What year and model Roadstar is it. On the pre 2006 models there is a standalone charger which can easily be turned off.

    On our 780/786 the charger was under the drivers side lounge seat and the on/off switch was easily knocked when storing items in the locker space.

    Lunarman
     
  7. Mikeco

    Mikeco Funster

    Joined:
    Sep 26, 2013
    Messages:
    595
    Likes Received:
    400
    Location:
    Market Rasen
    If your solar panel is working then that should be charging your leisure battery, you say that it is but how do you know.

    Mike
     
  8. davidb1327

    davidb1327 Read Only Funster

    Joined:
    Nov 17, 2013
    Messages:
    3
    Likes Received:
    0
    Location:
    Brigg
    Thanks for the Info.....

    Just to say thank you for the advice on what may be the problem. I will get my son-in-law (the family mechanic/handyman) to check all the points that have been mentioned and will let you all know the outcome good or bad...Thanks again....
     

Share This Page