Elddis Autoquest 120, 12v problem

Discussion in 'Motorhome Chat' started by Dolomite Pete, Nov 24, 2013.

  1. Dolomite Pete

    Dolomite Pete Read Only Funster

    Joined:
    Oct 13, 2013
    Messages:
    23
    Likes Received:
    7
    Location:
    Alton
    I've got an issue where by if I go over a fairly severe bump in the road, the camper 12v system completely drops out! I've checked the master on/off switch by the door and that's OK, also checked the battery connections; OK. It has happened twice and has come back on after driving for a while. Any ideas? The only thing I can think of is the relais operated by the master switch. I haven't been able to find that yet; is it part of the fuse box under the rear seat? Any help greatly appreciated!
     
  2. tick59

    tick59 Funster

    Joined:
    Dec 25, 2007
    Messages:
    1,241
    Likes Received:
    1,087
    Location:
    Newcastle Upon Tyne
    :thumb::thumb:
    CHECK THE ROCKER SWITCH ON THE MAIN CONSUL WHERE YOUR TV PLUGS IN THE SWITCH FOR THE BATTERY MUST BE ON "LEISURE BATTERY" SOMETIMES THIS GETS INADVERTANLY MOVED.
     
  3. Moodybrook

    Moodybrook Funster

    Joined:
    Jul 7, 2013
    Messages:
    754
    Likes Received:
    628
    Location:
    Dumfries
    On my Elddis when on the move my 12v "Habitation" circuit is always disabled. I understand that is normal ? Or do you mean your driving lights:Smile:
     
  4. tick59

    tick59 Funster

    Joined:
    Dec 25, 2007
    Messages:
    1,241
    Likes Received:
    1,087
    Location:
    Newcastle Upon Tyne
    :thumb::thumb:
    THAT'S THE SAME ON MINE. ENGINE RUNNING NO 12V. ENGINE STOPPED 12V OK.
     
    • Like Like x 1
Loading...

Share This Page