dometic blizzard 1800 aircon blowing warm

Discussion in 'Tech/Mech General' started by N&K, Sep 1, 2011.

  1. N&K

    N&K

    Joined:
    May 26, 2008
    Messages:
    220
    Likes Received:
    42
    Location:
    Berkshire
    hi

    my mum had the dometic blizzard fitted to her caravan 10 years ago. Recently it starts
    to blow warm after about am hour of use. Its been hot outside and we are wondering
    if its on its last legs or if its not coping with v hot days. its just been regassed there are no leaks. anyone had this problem?

    cheers
     
  2. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    Tell her to keep her mouth shut. Oh sorry thought you said domestic:Rofl1::Rofl1::Rofl1::Rofl1:
     
  3. N&K

    N&K

    Joined:
    May 26, 2008
    Messages:
    220
    Likes Received:
    42
    Location:
    Berkshire
    Knob.
     
  4. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,461
    Likes Received:
    16,889
    Location:
    YO11 2BD
    was it regassed due to age or was there an existing problem ?

    if it was ok before re-gassing then return to the engineers/workshop and ask them to sort it.....if it worked before its their problem now.
     
  5. N&K

    N&K

    Joined:
    May 26, 2008
    Messages:
    220
    Likes Received:
    42
    Location:
    Berkshire
    thanks pappajohn. before it was regassed it was doing the same but the engineer
    didnt know what was causing it. it was hoped a regas might fix it i think. the engineer
    said it might have a leak but could not find one.
     
  6. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,461
    Likes Received:
    16,889
    Location:
    YO11 2BD
    if it had a leak the engineer would have found it using his UV goggles/glasses.....he did use goggles i presume ?

    the gas/lubricant usually has a UV dye in it and will show any leaks.

    if it did it before the re-gas it could be the compressor failing when it gets hot or a partially blocked radiator core.

    probably cheaper to replace than repair.:Sad:
     
  7. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    what the hell is wrong with people on here that you reply to a joke, a bit of fun with a personal insult, not on old cock
     
  8. Geo

    Geo Trader - Funster

    Joined:
    Jul 29, 2007
    Messages:
    9,508
    Likes Received:
    5,563
    Location:
    Mansfield,Notts
    Me thinks your comedy timing slipped Rodger:Rofl1:
    It may be good to let em get an answer or two before giving them the benifit of your wisdom:thumb:
    Says he who always seems to get the timing wrong:Doh:
    Geo
     
  9. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    to quote JJ
    "comedy is a serious business" and I am bankrupt:Rofl1::Rofl1::Rofl1::Rofl1:
     
  10. N&K

    N&K

    Joined:
    May 26, 2008
    Messages:
    220
    Likes Received:
    42
    Location:
    Berkshire
    1. you were not replying to "a joke" you were replying to a serious question.
    2. a "personal insult" against someone elses mother is not humour.

    i happen to respect my family and would not tell my OAP mother to "shut up".

    Administrator - suggest you delete this thread. thanks.
     
  11. Wildman

    Wildman Read Only Funster

    Joined:
    May 30, 2008
    Messages:
    15,458
    Likes Received:
    8,598
    Location:
    Ilfracombe, Devon
    I did not reply to a joke I created one and sorry if it offended you as a joke it was not intended to offend, not to worry will keep out of your hair from now on
     
  12. haganap

    haganap Funster Life Member

    Joined:
    Dec 5, 2007
    Messages:
    11,066
    Likes Received:
    13,668
    Location:
    Heavan
    Hi N&K, I know its a long shot but you have had it regassed, there is no leaks, so you have carried out what I would of thought the simple solutions. However, this once happened to someone I know.

    If it is a dometic like mine, is there any possibility the tempreture control knob, (sorry no pun intended) is somehow broken and stuck on warm? On mine, I can ask for hot air and cold air so presumably yours is the same. I know it's a long shot, but it seems you have checked everything else.
     
  13. N&K

    N&K

    Joined:
    May 26, 2008
    Messages:
    220
    Likes Received:
    42
    Location:
    Berkshire
    Thanks Haganap, we checked the knob (liked your pun) but unfortunately it seemed fine.
    But in the end we removed the cover and found the radiator to be clogged up with grime.
    After a good scrub with a toothbrush it seems ok now. Maybe it was overheating and turning off. We are in Spain and the local engineer isnt brilliant he didnt say it was dirty maybe he saw it as an oportunity to fit a new one and more trade for him.
    cheers.
     
    • Like Like x 1
Loading...

Share This Page