Control panel NE 222

Discussion in 'Tech/Mech General' started by bobch, May 31, 2010.

  1. bobch

    bobch Read Only Funster

    Joined:
    May 31, 2010
    Messages:
    2
    Likes Received:
    0
    Location:
    North East Hampshire
    I have the above contol panel showing Blown Fuse N13 any ideas please this is on a Bessacar E660 2009 model
     
  2. Ash

    Ash Trader - Service & Repairs Life Member

    Joined:
    Sep 22, 2007
    Messages:
    766
    Likes Received:
    189
    Location:
    The Midlands ( Nuneaton )
    Look in your fuse compartment , find N13 and it will have blown , but you need to find out what has blown it ..
    Ash
     
  3. bobch

    bobch Read Only Funster

    Joined:
    May 31, 2010
    Messages:
    2
    Likes Received:
    0
    Location:
    North East Hampshire
    All fuses are lettered F and are all ok
     
  4. Ash

    Ash Trader - Service & Repairs Life Member

    Joined:
    Sep 22, 2007
    Messages:
    766
    Likes Received:
    189
    Location:
    The Midlands ( Nuneaton )
    You can give me a ring if you like and i will go through a few things with you , i have sent my phone number to your private message inbox .
    Ash
     
  5. jock

    jock Read Only Funster

    Joined:
    Jun 20, 2010
    Messages:
    2
    Likes Received:
    0
    fuse n13

    I have a Swift Kon tiki 2009 with the same problem. everything works, just comes up with the message....any ideas please...
    Many thanks
     
  6. jock

    jock Read Only Funster

    Joined:
    Jun 20, 2010
    Messages:
    2
    Likes Received:
    0
    fuse N13

    I have a Swift Kon tiki same problem, no fuse blown, everything works. Seens to happen once, then display shown normal!!

    Any one can help please...

    Thanks
     
  7. Theboot

    Theboot Read Only Funster

    Joined:
    Feb 21, 2015
    Messages:
    1
    Likes Received:
    0
    Location:
    Woodbridge
    I have a Swift Voyager with exactly the same fuse problem but it also appears to wrongly control the outside step when the power button on the control panel is pressed. I have a ne222 control panel. Any advice on how you solved your problem would be appreciated. Thanks
     
Loading...

Share This Page