Control/ display panel on Burstner elegance driving me mad!!!

Discussion in 'Motorhome Chat' started by Dai Motorhome, Mar 8, 2014.

  1. Dai Motorhome

    Dai Motorhome Read Only Funster

    Joined:
    Nov 27, 2012
    Messages:
    151
    Likes Received:
    19
    Location:
    Burnham on Sea, Somerset
    Hi all, for some strange reason 'something ' is switching the 12volt off and then back on In my Elegance i700. The control panel suddenly shows a message '12 v off' and then after a little while, the control panel lights back up and everything is normal.sometimes it is off for just a few seconds, other times for twenty minutes or so.:cry:
    Any suggestions welcomed!!
    Cheers
    David
     
  2. movan

    movan Funster Life Member

    Joined:
    Dec 2, 2009
    Messages:
    12,793
    Likes Received:
    22,305
    Location:
    Moving around
    How's about we get driven mad together? I am cheesed off with my Burstner panel. Try taking the fuses out and back in again ... on the solar panel thingy that sends power from the leisure batteries to the 12v battery.... Do you have a battery master?:Sad:
     
  3. pappajohn

    pappajohn Funster Life Member

    Joined:
    Aug 26, 2007
    Messages:
    29,441
    Likes Received:
    16,867
    Location:
    YO11 2BD
    i think you know my opinion of modern panels by now.

    I would have a decent autoelectrician remove the panel and show it what a hammer is for, then rewire the whole lot with a bank manual switches and digital meters.

    Far too complicated for what they are there for and Not fit for purpose
     
  4. hilldweller

    hilldweller Funster Life Member

    Joined:
    Dec 5, 2008
    Messages:
    26,414
    Likes Received:
    25,063
    Location:
    Macclesfield
    I'd take a guess....battery very low, drops below trip volts (about 11v), load cut off, battery recovers past 12v, panel switches back on.

    Stick a voltmeter on your battery.
     
  5. Wyaye wires

    Wyaye wires

    Joined:
    Sep 13, 2009
    Messages:
    3,831
    Likes Received:
    9,283
    Location:
    Berwickshire
    Please elaborate, and tell us more.
     
  6. Allanm

    Allanm Funster

    Joined:
    Jun 30, 2013
    Messages:
    3,028
    Likes Received:
    4,101
    Location:
    Cotes d'armor, France
    Does it happen in sunlight and do you have solar panels?
    There are a number of posts on other forums ( forii? :RollEyes:) where this has caused problems with some panels. I wonder if the circumstances are similar.
    Allan
     
    • Like Like x 1
  7. Dai Motorhome

    Dai Motorhome Read Only Funster

    Joined:
    Nov 27, 2012
    Messages:
    151
    Likes Received:
    19
    Location:
    Burnham on Sea, Somerset
    Control panel

    Eurika-well at least I hope so! I found that the mains lead to the motorhome had a corroded mains plug and the neutral in the plug was breaking down. So I guess the power was coming on and off intermittently as the lead flexed. Since ditching the lead I've had no problems! Let's hope it stays that way.
    Thanks for all the advice it is much appreciated
    Cheers all
    David:Smile::Smile::Smile::Smile:
     
    • Like Like x 1
Loading...

Share This Page