Carver water heater

Discussion in 'Tech/Mech General' started by Bessie600, Apr 19, 2016.

  1. Bessie600

    Bessie600 Funster

    Joined:
    Sep 14, 2015
    Messages:
    37
    Likes Received:
    33
    Location:
    Hertfordshire
    hi I'm trying to use my water heater on gas but none of the lights come on when I press the switch on, we have checked the main fuses but they seem ok, can anyone tell me what I'm doing wrong?
     

    Attached Files:

  2. RichardB

    RichardB Funster

    Joined:
    Oct 19, 2013
    Messages:
    195
    Likes Received:
    103
    Location:
    East Yorkshire
    Is your 12v system turned on and batteries charged?
     
  3. Wickolad

    Wickolad Funster

    Joined:
    Sep 10, 2013
    Messages:
    479
    Likes Received:
    517
    Location:
    Wickersley
    As RichardB says and also don't forget to remove the outside exhaust cover.
     
  4. Bessie600

    Bessie600 Funster

    Joined:
    Sep 14, 2015
    Messages:
    37
    Likes Received:
    33
    Location:
    Hertfordshire
    Yes everything is charged up gas heating working ok just not the hot water
    Where is the outside exhaust cover?
     
  5. RichardB

    RichardB Funster

    Joined:
    Oct 19, 2013
    Messages:
    195
    Likes Received:
    103
    Location:
    East Yorkshire
    There may not be an outside cover to remove - it depends on what water heater you have. If it is a Carver Cascade it will probably have a square vent outside with no removable cover.

    If you press the buttons and there are no lights, I can only think it is either a blown fuse, or a loose wire - either in the wall sockets or where the cables connect to the heater - I really can't think of anything else that would stop their being any lights on - if it was a fault with the heater you should get some indication of red lights...
     
    • Like Like x 1
    • Useful Useful x 1
  6. Bessie600

    Bessie600 Funster

    Joined:
    Sep 14, 2015
    Messages:
    37
    Likes Received:
    33
    Location:
    Hertfordshire
    Thanks yes I think the lights have blown got heater working ok
     
Loading...

Share This Page