carver cascade 2ge

Discussion in 'Motorhome Chat' started by 00mick00, Mar 25, 2012.

  1. 00mick00

    00mick00 Read Only Funster

    Joined:
    Mar 16, 2010
    Messages:
    23
    Likes Received:
    2
    Location:
    Leeds, West Yorkshire
    \Hi all, hope you've all enjoyed the weather this weekend, i have been repairing a leaky water heater and was just patting myself on the back for a job well done when i discovered a new problem, the water heats up lovely, tank gets hot, but when you run the hot taps the water only stays hot for about 30 seconds and then runs cool, does anyone know what could cause this, i'm puzzled, could it be a faulty valve on the cold inlet ? I've changed the tank, tie rod and all seals, thats it. suggestions please.
     
  2. spannermanwigan

    spannermanwigan Read Only Funster

    Joined:
    May 22, 2008
    Messages:
    394
    Likes Received:
    207
    Location:
    wigan, lancs
    Is it possible you have got the water pipes crossed over, at the heater cold to hot and vice versa.

    regards
    Steve
     
  3. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,223
    Likes Received:
    9,603
    Location:
    Dorset
    or a sticky non return valve on the cold feed to the heater can cause this
     
  4. 00mick00

    00mick00 Read Only Funster

    Joined:
    Mar 16, 2010
    Messages:
    23
    Likes Received:
    2
    Location:
    Leeds, West Yorkshire
    No Steve, never removed them,
     
  5. 00mick00

    00mick00 Read Only Funster

    Joined:
    Mar 16, 2010
    Messages:
    23
    Likes Received:
    2
    Location:
    Leeds, West Yorkshire
    its the only thing i can think of but wasnt sure, may have to change it to rule it out if i can't find anything else, theyre only about 6 quid,
     
Loading...

Share This Page