Carioca 656 control panel

Discussion in 'CI Motorhomes' started by Cat, Jan 13, 2013.

  1. Cat

    Cat Read Only Funster

    Joined:
    Jan 13, 2013
    Messages:
    5
    Likes Received:
    0
    Location:
    North yorkshire
    Have disconnected my battery and now control panel doesn't work. Anyone had this problem before?

    Dave
     
  2. 656

    656 Read Only Funster

    Joined:
    Jul 30, 2007
    Messages:
    1,150
    Likes Received:
    291
    Location:
    The universe
    If you speak to Steve Smith at Autotrail (01472 571000), he will send you a PDF of the user manual for your control panel.
     
  3. DP_JAY

    DP_JAY Funster Life Member

    Joined:
    Mar 17, 2010
    Messages:
    1,798
    Likes Received:
    1,022
    Location:
    Cark, Cumbria
    It wont with battery disconected
     
  4. Cat

    Cat Read Only Funster

    Joined:
    Jan 13, 2013
    Messages:
    5
    Likes Received:
    0
    Location:
    North yorkshire
    Sorry I should have put once I reconnected the battery the panel wouldn't work :)
     
  5. rainbow chasers

    rainbow chasers Read Only Funster

    Joined:
    Oct 30, 2009
    Messages:
    3,747
    Likes Received:
    1,720
    Location:
    Mid Cornwall
    Check the fuses on the hab side of the main battery, and the leisure battery fuse, which will be nearby, but not in the battery box - you probably had a surge pop the fuse when you reconnected.

    For the leisure one, look under the seat near the battery area - they are usually screwed to the floor.
     
  6. 656

    656 Read Only Funster

    Joined:
    Jul 30, 2007
    Messages:
    1,150
    Likes Received:
    291
    Location:
    The universe
    All the fuses fpr the Hab area are in a box behind the drivers seat. Well, they are in my 656.:Rofl1:
     
  7. Cat

    Cat Read Only Funster

    Joined:
    Jan 13, 2013
    Messages:
    5
    Likes Received:
    0
    Location:
    North yorkshire
    Thanks everyone, have checked all fuses and all ok. Have just ordered new control panel from Italy so hopefully that will solve the problem ;-)
     
  8. Phill D

    Phill D

    Joined:
    Dec 6, 2011
    Messages:
    4,414
    Likes Received:
    4,632
    Location:
    South Wales
    Dont hold your breath on it coming any time soon. I HAD A CARIOCA 746 took 3 months for a bumper part to come and 18 months for a habitation door to arrive.....:Doh::cry:
     
  9. magicsurfbus

    magicsurfbus Funster

    Joined:
    Oct 11, 2010
    Messages:
    3,503
    Likes Received:
    8,254
    Location:
    NW England
    I had Control Panel/Fuse Board problems in my 2005 reg 656, and in the end, after various attempts by various people, I had it all sorted by Geoff Cox of Derby, who are the CI dealers whom we bought the MH from. In my case it was to do with inaccurate monitoring of the engine battery and I needed a new fuse board, which cost £200 plus labour.

    I'm not sure which year your 656 is but have you looked under the driver's seat in front of the charger to see if the in-line blade fuse is OK? At one point mine managed to blow.

    Might be worth checking whether or not your fridge works on 12v with the engine running, and whether your blown air heater fan is working. Your fridge is dependent upon the fuse board behind the driver's seat, and my heating fan is independent of the control panel, so I'm assuming yours might be too. If neither of those were working the problem may not be in the Control Panel itself, which is a fairly simple component with a few lights and switches on it. The actual controlling of the electricity supply is done by the fuse board, which is far more complicated.
     
Loading...

Share This Page