Brake Lights not working

Discussion in 'American RV's' started by Alegro88, May 17, 2009.

  1. Alegro88

    Alegro88 Read Only Funster

    Joined:
    Sep 13, 2008
    Messages:
    4
    Likes Received:
    0
    Location:
    Swindon, Wiltshire
    Dear All, i need some advice please

    I have a 1988 tiffin allegro built on a gmc/chevy light van

    the brake lights dont work when pedal pressed, the rest of the lights work

    checked all the bulbs, fuses and wires etc

    I cant find out about the electrical brake switch, somone said it maybe an inline one?

    I live in swindon and so if anyone knows of a chap that could come over and run a test on the wiring. You know an old fashioned chap that know about stuff instead of a very pricey auto electrician more intested in chipping the lasted suburu to 300bhp etc

    Any advice would be greatfully accepted as it needs an mot and there no paying for it to fail

    Thanks


    Allegro 88 - swindon
     
  2. American Dream

    American Dream Read Only Funster

    Joined:
    Aug 20, 2007
    Messages:
    6,489
    Likes Received:
    154
    Location:
    Lincoln
    Hi Allegro 88

    Have you checked for voltage at the bulb holders with a multimeter/swapped known good bulbs to the brake lamp sockets.

    I personally think it would be more likely to be a fuse blown.Have you visually checked all fuses?

    Just a thought.The brake switch isn't mounted above the brake pedal and actuated by a spring is it?

    It may have come off.
     
    Last edited: May 17, 2009

Share This Page