Bessacarr E445 charging problem

Discussion in 'Motorhome Chat' started by KeithTBRS, Jan 2, 2014.

  1. KeithTBRS

    KeithTBRS Read Only Funster

    Joined:
    Jan 2, 2014
    Messages:
    4
    Likes Received:
    0
    Location:
    Lymington
    Hi all

    Wonder if anybody can help.

    I have an e445, the house battery charges fine from the mains supply, but will no longer charge from the engine. I am sure this a simple popped fuse, but I cannot find which fuse, does anybody know the location.

    Pretty sure this stopped working when the engine was started with mains lead still plugged in.

    Many thanks

    Keith
     
  2. KeithTBRS

    KeithTBRS Read Only Funster

    Joined:
    Jan 2, 2014
    Messages:
    4
    Likes Received:
    0
    Location:
    Lymington
    Did anyone one have any thoughts on this???


     
  3. meanders

    meanders Funster - Life Member Life Member

    Joined:
    Jun 28, 2008
    Messages:
    552
    Likes Received:
    318
    Location:
    Ipswich, Suffolk
    Hi.

    I suggest you start with Googling the swift site for the manual with circuit diagrams. On our 435 the 12 v fuse board is behind the drivers seat. Your's is likely to be in the same place. It's relatively easy to trace through.

    Also, check your main control panel that you haven't inadvertently selected to use the vehicle battery instead of the on board. If you do, the engine will never charge the leisure battery.

    Best wishes .... Robin
     
Loading...

Share This Page