Been having great time in 1994 fiat hymer but

Discussion in 'Tech/Mech General' started by nunny666, Aug 20, 2015.

  1. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Hi all , been having a great time in our hymer ( 1994fiat ducato )but on last trip when I put indicator on left turn the flasher relay got got and blew the fuse (same if I put hazards on ) right turn is ok , is it common for the problem to be indicator stalk , if so how do I get the funny shape nut with flat edge off to get steering wheel removed , any other possible causes appreciated , thanks in advance ,can tell its mot time early sept lol , nunny,
     
  2. Flamenca

    Flamenca Funster Life Member

    Joined:
    Jun 21, 2013
    Messages:
    757
    Likes Received:
    453
    Location:
    Cornwall/France/Spain
    I would not start fault finding with the stalk. Initially I would remove both left hand indicator bulbs and see what happens when you set stalk as if turning left (with ignition on and new fuse inserted).
     
    • Like Like x 1
  3. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Cheers will the light on dash still illuminate if I remove bulbs then test , will try tomorrow after work and report back
     
  4. Stealaway

    Stealaway Funster

    Joined:
    Jan 8, 2013
    Messages:
    968
    Likes Received:
    1,103
    Location:
    Dronfield - Derbyshire
    Wot 'e said.
    Check the light clusters first, they are aluminium and probably corroded and shorting after this long
     
    • Like Like x 1
  5. Flamenca

    Flamenca Funster Life Member

    Joined:
    Jun 21, 2013
    Messages:
    757
    Likes Received:
    453
    Location:
    Cornwall/France/Spain
    Yes the dash lamp should illuminate but not flash. I recommended starting at the bulb end of the circuits for two reasons. It is the easiest part to check and I had a similar situation a few years ago caused by corrosion on the bub cap.
    Do you have a multi-tester to help undertake further tests?
     
    • Like Like x 1
  6. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Yes I have multi meter to aid in checking , is it continuity I need to set it on ?thanks guys
     
  7. Flamenca

    Flamenca Funster Life Member

    Joined:
    Jun 21, 2013
    Messages:
    757
    Likes Received:
    453
    Location:
    Cornwall/France/Spain
    Check with bulbs removed first. You might not have to look any further.
     
    • Like Like x 1
  8. Hymie

    Hymie Funster

    Joined:
    Nov 29, 2013
    Messages:
    592
    Likes Received:
    674
    Location:
    Essex
    Hi Nunny, if the wiring is the same layout as my 1991 Hymer there are 2 junction boxes underneath near the rear axle. both mine had lost the lids and the wiring junction, just chocolate blocks, was completely corroded.

    I replaced the boxes for new with watertight grommets, replaced the chocolate blocks and had my indicators back on line.

    Total cost around 15 quid, the bloke at the garage quoted me around 140 quid as he needed to replace all the connector blocks apparently. :ROFLMAO::ROFLMAO::ROFLMAO:

    Don't forget to take picture of each one before you remove the blocks.

    Hymie.
     
    • Like Like x 2
  9. TheBig1

    TheBig1 Funster Life Member

    Joined:
    Nov 27, 2011
    Messages:
    7,224
    Likes Received:
    9,612
    Location:
    Dorset
    i would say its a short in the wiring, not a stalk issue. as above start at rear light and check/repair all joints and the bulb
     
    • Like Like x 1
  10. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    I have one box as you state underneath on Friday when I had drove in rain I took cover off the box and it was full of water , the wiring was connected with plastic block connector and spades ,
     
  11. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Will have a play tomorrow night and report back , thanks for the input
     
  12. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Thanks all can't wait to get to bottom of it ,
     
  13. Hymie

    Hymie Funster

    Joined:
    Nov 29, 2013
    Messages:
    592
    Likes Received:
    674
    Location:
    Essex
    sounds like the seat of your problem to me, good luck.

    got my boxes and grommets from Amazon.

    Hymie
     
    • Like Like x 1
  14. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    So I didn't get round to doing anything last night as my dad got rushed into hospital , had a look this morning , undid and put new connectors to the left side box under and to rear of hymer , removed all indicator bulbs to left , right indicators work and dash lite is bright , left side dash lite is dull ( even with bulbs in too ) , and flasher relay gets red hot ( melting hot ) with bulbs in and without bulbs in ,
     
  15. Hymie

    Hymie Funster

    Joined:
    Nov 29, 2013
    Messages:
    592
    Likes Received:
    674
    Location:
    Essex
    Sorry to hear about your Dad, wish him a speedy recovery.

    Are you sure about only one box underneath?

    On mine each side is fed independently from the respective front side.

    Hymie
     
    • Like Like x 1
  16. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    No theirs two , one on right and one on left , but didn't bother doing anything to right side as the problems left indicators .should I re new connectors in right box too you reckon . Thanks
     
  17. Hymie

    Hymie Funster

    Joined:
    Nov 29, 2013
    Messages:
    592
    Likes Received:
    674
    Location:
    Essex
    If the box has leaked you are storing up problems for later, so I would do it while you have decent weather rather than possibly in the dead of winter.

    Hymie.
     
    • Like Like x 1
  18. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Noticed if I push indicator stalk slight forward while on left indicator sometimes the dash light lights up as bright as right one dash display , but only for one flash ,
     
  19. nunny666

    nunny666

    Joined:
    Apr 10, 2014
    Messages:
    232
    Likes Received:
    41
    Location:
    huddersfield
    Awaiting another flasher unit 4 pin as I think the new one I purchased after first one melted before fuse blew is now duff as buzzes when on left turn , works on right turn , Perrys in Huddersfield charged me 40 pound for the 4 pin relay , but if a rip off , so looking elsewhere
     
  20. Stealaway

    Stealaway Funster

    Joined:
    Jan 8, 2013
    Messages:
    968
    Likes Received:
    1,103
    Location:
    Dronfield - Derbyshire
    • Like Like x 1
Loading...

Share This Page